DPSearch: Upgrade Issues Due to crda-3.18-8.1.x86_64 Package

Summary: Upgrade of DPSearch runs for a few days and never completes. No reboot is done. DPSearch upgrade fails with error code: 254

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

This may be shown in the PowerProtect Data Protection Appliance (Integration Data Protection Appliance) Rapid Upgrade ChecKer (RUCK).

NOTE: For Integration Data Protection Appliance RUCK Check warning, see the resolution at the end of this KB.

DPSearch upgrade fails with error code: 254

The following is seen in the /mnt/search/log/puppet/puppet_agent.log:
Preparing...                          ########################################
                package crda-3.18-8.1.x86_64 (which is newer than crda-1.1.3-4.5.1.x86_64) is already installed
Apply SUSE patches failed with error code:254!
2022-08-30T11:24:31,596|workername|WARN|upgrade.sh:(line 337)|Execute package upgrade script failed with exit code: 254!
2022-08-30T11:24:31,603|workername|WARN|upgrade.sh:(line 254)|previous step exit code indicate we should exit now.

During DPSearch upgrade, it can run in a loop and not complete as intended. 

The upgrade status does not change to xxxx.zip-completed in the /etc/puppet/status.

It continues going in a loop with these errors.

Cause

This issue is the result of failing to upgrade the CRDA binary. The version that is already present in the system is a higher version than what it is being upgraded to.

This triggers an error in the SUSE Linux update, and then it fails to upgrade Search.

Resolution

To address this issue and allow the upgrade to complete, uninstall the package that is preventing the upgrade.

From a PuTTY session connected to the Search server, run the following command to remove the conflicting package:
rpm -e crda-3.18-8.1.x86_64

The installation restarts, and installs the proper package from the upgrade workflow.

For Integration Data Protection Appliance, this gets identified with the RUCK Tool. Run the above command on all Search nodes.

For DP8x00 models, this must be run on the two Index nodes as well before the upgrade is started. See the related article PowerProtect Data Protection Appliance - Integration Data Protection Appliance: Procedure To Independently Upgrade Search Component 

Article Properties
Article Number: 000203324
Article Type: Solution
Last Modified: 14 Mar 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.