PowerScale: OneFS 9.7.1.3/9.10.0.0 and above and InsightIQ 5.0/5.1 are incompatible

Summary: If a cluster is on or is upgraded to OneFS version 9.7.1.3/9.10.0.0 or later and connected to InsightIQ 5.0/5.1, it stops or fails to monitor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

InsightIQ shows Monitoring Halted: Exception or Monitoring Halted: APIMissingError

It can also have a delete cluster message which is incorrect. 

Cause

InsightIQ uses an older Application Programming Interface (API) call that was changed in the newer OneFS version 9.7.1.3/9.10.0.0 and later on those versions. 9.8 and 9.9 versions are not affected.  

Resolution

If planning on upgrading to 9.7.1.3/9.10.0.0 or later version, it is advised to pause the upgrade until after InsightIQ has been upgraded to 5.2 or later. 

If planning to upgrade to OneFS 9.7.1.3/9.10.0.0 or later and using InsightIQ 4.x, an upgrade to 5.2 or later is required. This is due to InsightIQ 4.x not being compatible with 9.7 and later. Due to this, it is advised to pause the upgrade until after InsightIQ 5.2 or later has been launched.

If OneFS has already been upgraded to 9.7.1.3/9.10.0.0 or later and InsightIQ version is 5.0 or 5.1, an upgrade to InsightIQ 5.2 or later is needed. Dell Technologies apologizes for any inconvenience and loss of monitoring this has caused. 

If additional information is required or needed, contact either support or your account team. 

Products

PowerScale OneFS, PowerScale InsightIQ
Article Properties
Article Number: 000251368
Article Type: Solution
Last Modified: 16 Dec 2025
Version:  6
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