Avamar: Backups Fail to Start with Avagent Warning "TCP timeout on receive ack"

Summary: This article provides solutions for backups failing due to networking issues.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Backups (scheduled and on-demand) fail to start with Timed Out - Start message in the Activity Window of the Avamar Administrator console. The following messages may be seen in the avagent.log file (usually in C:\Program Files\avs\var folder) on the Windows clients:

avagent Warning <6584>: TCP timeout on receive ack
avagent Warning <5473>: Null message received from MCS

Cause

There is a possible "black hole router" issue between the Avamar grid and the Windows client, especially across WAN links. See the following article for more information: 
https://en.wikipedia.org/wiki/Black_hole_(networking) This hyperlink is taking you to a website outside of Dell Technologies.

Resolution

Run ping commands from the Avamar grid to the Windows client and conversely, using the -f and -l parameters.

  • The -f parameter causes the Ping utility to send an Internet Control Message Protocol (ICMP) echo packet that has the IP "do not fragment" bit set.
  • The -l parameter sets the buffer, or payload, size of the ICMP echo packet. You specify this size by typing a number after the -l parameter.

Command syntax:

ping <<computer_name or IP_address>> -f -l 1472

Example:

ping server.dell.com -f -l 1472

For all local IP addresses, the expected results are as follows:

  • If the MTU of every segment of a routed connection is at least 1,500, the packet is successfully returned.
  • There are intermediate segments that have smaller maximum transmission units (MTU), and the routers return the appropriate ICMP "destination unreachable" packet. The ping utility displays the message, "Packet needs to be fragmented but DF set."
  • There are intermediate segments that have smaller MTUs, and the routers do not return the appropriate ICMP "destination unreachable" packet. The ping utility displays the message, "Request timed out."

Avamar: Troubleshooting slow backup performance

Affected Products

Avamar, Avamar Client for Windows
Article Properties
Article Number: 000165966
Article Type: Solution
Last Modified: 16 Oct 2025
Version:  4
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