NVP-vProxy: 백업 실패 - 가상 디스크 "하드 디스크 1"을 백업할 수 없음 - VMDK를 오픈 소스하지 못함
Summary: NetWorker VMware Protection 통합은 vProxy 어플라이언스로 구성됩니다. 환경에서 가상 머신 백업이 완료되지 않습니다. NetWorker Management Console 메시지는 가상 디스크 "하드 디스크 1"을 백업할 수 없음을 나타냅니다. vProxy 어플라이언스를 호스팅하는 ESX 호스트에 HBA에 문제가 있어 백업을 수행하는 데 필요한 디스크 정보를 검색할 수 없습니다. vProxy 어플라이언스가 상주하는 ESX 호스트를 조사합니다. 필요에 따라 또는 해결 방법으로 VMware 지원 팀에 문의하거나 해결 방법으로 vProxy 어플라이언스를 다른 ESX 호스트로 vMotion합니다. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
NetWorker VMware Protection 통합은 vProxy 어플라이언스로 구성됩니다. 환경에서 가상 머신 백업이 완료되지 않습니다. NetWorker Management Console 메시지는 가상 디스크 "하드 디스크 1"을 백업할 수 없음을 나타냅니다.
그림 1: 실패한 VM 백업에 대한 백업 작업 메시지입니다.
vProxy vbackupd-engine.log 파일 및 NetWorker Server 백업 로그에는 다음이 표시됩니다.
vProxy vbackupd-vddk.log 파일에 다음이 표시됩니다.
그림 1: 실패한 VM 백업에 대한 백업 작업 메시지입니다.
vProxy vbackupd-engine.log 파일 및 NetWorker Server 백업 로그에는 다음이 표시됩니다.
YYYY/MM/DD HH:MM:SS TRACE: [43] Opening source VMDK "[DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk" ...
YYYY/MM/DD HH:MM:SS INFO: [43] Calling VixDiskLib_Open("[DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk")...
YYYY/MM/DD HH:MM:SS ERROR: [43] VDDK Error: 13: You do not have access rights to this file.
YYYY/MM/DD HH:MM:SS ERROR: [43] Failed to open source VMDK "[DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk".
YYYY/MM/DD HH:MM:SS ERROR: [43] "Hard disk 1": BackupVmdk: "Hard disk 1": Unable to open Virtual Disk "[DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk" in "hotadd:nbd" mode.
YYYY/MM/DD HH:MM:SS ERROR: [43] "Hard disk 1": BackupVmdk: "Hard disk 1": Unable to open Virtual Disk "[DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk" in "hotadd:nbd" mode.
YYYY/MM/DD HH:MM:SS ERROR: [43] "Hard disk 1": BackupVmdk: Failed backup.
YYYY/MM/DD HH:MM:SS ERROR: [43] Unable to backup virtual disk "Hard disk 1".
vProxy vbackupd-vddk.log 파일에 다음이 표시됩니다.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO YYYY-MM-DDTHH:MM:SS error -[7F4EE8059700] [Originator@6876 sub=transport] Reconfigure attempt failed for VM "vm-123" with Vmomi::MethodFault::Exception ("vim.fault.InvalidDeviceSpec")
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO YYYY-MM-DDTHH:MM:SS error -[7F4EFC315740] [Originator@6876 sub=transport] Mounting VM vm-35 using transport hotadd failed : Failed to hot-add SCSI targets: Vmomi::MethodFault::Exception: vim.fault.InvalidDeviceSpec.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO YYYY-MM-DDTHH:MM:SS error -[7F4EFC315740] [Originator@6876 sub=transport] Cannot use mode hotadd to access [DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk: Cannot mount using this method. (Mounting VM vm-35 using transport hotadd failed : Failed to hot-add SCSI targets: Vmomi::MethodFault::Exception: vim.fault.InvalidDeviceSpec.)
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: Unable to locate appropriate transport mode to open disk. Error 13 (You do not have access rights to this file) (Mounting VM vm-35 using transport hotadd failed : Failed to hot-add SCSI targets: Vmomi::MethodFault::Exception: vim.fault.InvalidDeviceSpec.) at 4905.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_OpenEx: Cannot open disk [DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk. Error 13 (You do not have access rights to this file) (Mounting VM vm-35 using transport hotadd failed : Failed to hot-add SCSI targets: Vmomi::MethodFault::Exception: vim.fault.InvalidDeviceSpec.) at 5026.
YYYY/MM/DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Open: Cannot open disk [DATASTORE_NAME] [VM_NAME]/[VM_NAME].vmdk. Error 13 (You do not have access rights to this file) at 5064.
Cause
vProxy 어플라이언스를 실행하는 ESXi 호스트에 HBA(호스트 버스 어댑터)에 문제가 있어 백업을 수행하는 데 필요한 디스크 정보를 검색할 수 없습니다. 디바이스 규격에 잘못된 값이 포함되어 가상 머신 구성이 실패하는 경우 VMware VDDK(Virtual Disk Development Kit) InvalidDeviceSpec 예외가 발생합니다.
Resolution
vProxy 어플라이언스가 상주하는 ESXi 호스트에서 HBA 문제를 조사합니다. 필요에 따라 VMware 지원 부서에 문의하십시오.
해결
vProxy 어플라이언스를 다른 ESXi 호스트로 vMotion
해결
vProxy 어플라이언스를 다른 ESXi 호스트로 vMotion
Additional Information
vProxy vbackupd-vddk.log 및 vbackupd-engine.log 파일은 vProxy의 /opt/emc/vproxy/runtime/logs/vbackupd/ 디렉토리에 있습니다.
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000035425
Article Type: Solution
Last Modified: 02 Nov 2023
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.