Avamar: VM Image Backup reports Warning <16277>: vSphere Task failed (application quiesce)

Summary: Avamar VM Image Backup completed with exception/warning: avvcbimage Warning <16277>: vSphere Task failed (application quiesce)

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Symptoms

Avamar VM Image Backup completed with exception/warning: avvcbimage Warning <16277>: vSphere Task failed (application quiesce) 

Application quiesce consistent snapshot failed.

Relevant portion from the backup log:

2018-12-20 19:25:32 avvcbimage Warning <16277>: vSphere Task failed (application quiesce): 'An error occurred while quiescing the virtual machine. See the virtual machine's event log for details.'. 2018-12-20 19:25:32 avvcbimage Warning <43652>: Snapshot 'Avamar-XXXXXXXXX' creation for VM '[<DATASTORE_NAME>] <PATH_TO_VMs_FILES>.vmx' task creation encountered a quiesce problem 2018-12-20 19:25:32 avvcbimage Warning <43656>: Application consistent snapshot quiesce failure. 2018-12-20 19:25:32 avvcbimage Warning <43657>: The VM could not be quiesced prior to snapshot creation and this backup may not be used as a base for subsequent CBT backups if successful. 2018-12-20 19:25:32 avvcbimage Warning <40711>: Consider using the pre-freeze and post-thaw scripts to facilitate VM quiescing 2018-12-20 19:25:32 avvcbimage Warning <41146>: This error might caused by the pre-freeze script returning a non-zero error code.


Correspondent logs from vmware.log from the VM's folder in the datastore:

2018-12-20T19:25:29.679Z| vmx| I125: SNAPSHOT: SnapshotPrepareTakeDoneCB: Prepare phase complete (The operation completed successfully). 2018-12-20T19:25:29.773Z| vcpu-0| I125: ToolsBackup: changing quiesce state: IDLE -> STARTED 2018-12-20T19:25:30.777Z| vmx| I125: Msg_Post: Warning 2018-12-20T19:25:30.777Z| vmx| I125: [msg.snapshot.quiesce.vmerr] The guest OS has reported an error during quiescing. 2018-12-20T19:25:30.777Z| vmx| I125+ The error code was: 3 2018-12-20T19:25:30.777Z| vmx| I125+ The error message was: The operation attempted is not supported. 2018-12-20T19:25:30.777Z| vmx| I125: ---------------------------------------- 2018-12-20T19:25:30.780Z| vmx| I125: ToolsBackup: changing quiesce state: STARTED -> ERROR_WAIT


 

Cause

Incorrect VM settings, missing "disk.EnableUUID=TRUE" attribute in "VM Options".
This could happen if the virtual machine with OS type  Windows Server 2016  was created using a Host Client.

Resolution

Add a virtual machine s disk.EnableUUID = TRUE attribute manually in VM Options.

Steps from https://kb.vmware.com/s/article/52815
  1. Open the Host Client, and log in to the ESXi.
  2. Locate the Windows Server 2016 virtual machine in question and power it off.
  3. After power-off, right-click the virtual machine, and choose Edit Settings.
  4. Click VM Options tab, and select Advanced.
  5. Click Edit Configuration in Configuration Parameters.
  6. Click Add parameter.
  7. In the Key column, type disk.EnableUUID.
  8. In the Value column, type TRUE.
  9. Click OK and click Save.
  10. Power on the virtual machine.

Additional Information

Check VMware KB for more info: https://kb.vmware.com/s/article/52815

Affected Products

Avamar

Products

Avamar, Avamar Client for VMware
Article Properties
Article Number: 000053007
Article Type: Solution
Last Modified: 03 Mar 2025
Version:  4
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