Avamar VM Image Backup completed with exception/warning : avvcbimage Warning <16277> : vSphere Task failed (application quiesce)
Symptoms
Avamar VM Image Backup completed with exception/warning : avvcbimage Warning 16277> : vSphere Task failed (application quiesce)
Application quiesce consistent snapshot failed.
<Partie pertinente du log de sauvegarde :
2018-12-20 19:25:32 avvcbimage Warning <16277> : vSphere Task failed (application quiesce) : 'An error occurred while quiescing the virtual machine. See the virtual machine's event log for details.'. 2018-12-20 19:25:32 avvcbimage warning <43652> : La création du snapshot « Avamar-XXXXXXXXX » pour la tâche de machine virtuelle « [<DATASTORE_NAME>] <PATH_TO_VMs_FILES.vmx> » a rencontré un problème de mise en veille 2018-12-20 19:25:32 avvcbimage warning <43656> : Application consistent snapshot quiesce failure. 2018-12-20 19:25:32 avvcbimage warning <43657> : La machine virtuelle n’a pas pu être mise en veille avant la création du snapshot et cette sauvegarde ne peut pas être utilisée comme base pour les sauvegardes CBT suivantes en cas de réussite. 2018-12-20 19:25:32 avvcbimage warning <40711> : Envisagez d’utiliser les scripts de pré-gel et de post-déblocage pour faciliter la mise en veille des machines virtuelles 2018-12-20 19:25:32 avvcbimage warning <41146> : Cette erreur peut être due au fait que le script de prégel renvoie un code d’erreur différent de zéro.
Les journaux correspondants à partir de vmware.log à partir du dossier de la machine virtuelle dans le datastore :
2018-12-20T19:25:29.679Z| vmx| Réf. I125 : INSTANTANÉ: SnapshotPrepareTakeDoneCB : Phase de préparation terminée (l’opération s’est terminée avec succès). 2018-12-20T19:25:29.773Z| VCPU-0| Réf. I125 : ToolsBackup : changing quiesce state : INACTIF -> DÉMARRÉ 2018-12-20T19:25:30.777Z| vmx| Réf. I125 : Msg_Post : Avertissement 2018-12-20T19:25:30.777Z| vmx| Réf. I125 : [msg.snapshot.quiesce.vmerr] Le système d’exploitation invité a signalé une erreur lors de la mise en veille. 2018-12-20T19:25:30.777Z| vmx| I125+ Le code d’erreur était : 3 2018-12-20T19:25:30.777Z| vmx| I125+ Le message d’erreur était le suivant : L’opération tentée n’est pas prise en charge. 2018-12-20T19:25:30.777Z| vmx| Réf. I125 : ---------------------------------------- 2018-12-20T19:25:30.780Z| vmx| Réf. I125 : ToolsBackup : changing quiesce state : DÉMARRÉ -> ERROR_WAIT
Cause
Cela peut se produire si la machine virtuelle avec le type de système d’exploitation Windows Server 2016 a été créée à l’aide d’un client hôte.
Resolution
À quelques pas de https://kb.vmware.com/s/article/52815
- Ouvrez le client hôte et connectez-vous à ESXi.
- Localisez la machine virtuelle Windows Server 2016 en question et mettez-la hors tension.
- Après la mise hors tension, cliquez avec le bouton droit de la souris sur la machine virtuelle, puis sélectionnez Edit Settings.
- Cliquez sur l’onglet VM Options , puis sélectionnez Advanced.
- Cliquez sur Modifier la configuration dans Paramètres de configuration.
- Cliquez sur Add parameter.
- Dans la colonne Key , saisissez disk. Activer l’UUID.
- Dans la colonne Value, saisissez TRUE.
- Cliquez sur OK , puis sur Save.
- Allumez la machine virtuelle.