Latitude XX80 video issues on external monitor attached to Dell Universal Dock (D6000 series)
Summary: Latitude XX80 laptops may experience video issues on external monitor connected to Dell Universal Dock (D6000 series).
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Symptoms
The Dell Latitude XX80 series laptop with a Skylake CPU and Windows installed may experience issues with the video on the external monitor attached to a Dell Universal Dock (D6000 series). This article provides more information on the issue and the steps to take for a solution.
Cause
Latitude XX80 video issues on external monitor
The Latitude XX80 series laptop with an Intel Skylake processor and Windows installed may experience video issues when connected to an external monitor using the Dell Universal Dock (D6000 series). The following issues may occur:- If the laptop is locked and unlocked or woken from sleep mode, the windows on the external monitor connected to the Dell Universal Dock (D6000 series) will not update.
- If video was playing before the laptop was locked or entered sleep mode, the video on the external monitor will freeze on the last frame visible before the laptop was locked or entered sleep mode. Video on the laptop's LCD should not be affected
NOTE: This issue was seen using Windows Media Player but may also appear with other media players.
- Other potential issues may occur when first connecting the dock, including all external monitors may shut off or the video drivers may become corrupt.
- These video issues can occur with both the USB-C and USB 3.0 connections on the Dell Universal Dock (D6000 series).
Resolution
To resolve these video issues, download the latest available DisplayLink driver from the location below. Choose the correct version of the Windows operating system from the list when downloading and installing the update:
Affected Products
Latitude 5280/5288, Latitude 7280, Latitude 13 3380, Latitude 7380, Dell Latitude 3480/3488, Latitude 5480/5488, Latitude 7480, Dell Latitude 3580/3588, Latitude 5580, Latitude 3480 mobile thin client, Latitude 5280 mobile thin clientArticle Properties
Article Number: 000134268
Article Type: Solution
Last Modified: 16 Feb 2024
Version: 5
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