Avamar : le déploiement du plug-in Dell EMC Avamar indique un état d’échec dans vSphere Client

Summary: Le déploiement du plug-in Dell EMC Avamar indique un état d’échec dans vSphere Client

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Symptoms

Dans le menu Avamar AUI > Administration > System > VMware Plugin, le plug-in VMware semble inscrit et la version correspond à la version d’Avamar Server. 

aui-plugin-registered.png


Dans vSphere Client, le plug-in Avamar n’est cependant pas visible pas dans l’écran Home > Menu. 

le plug-in est manquant


Le menu vSphere Client Administration > Solutions > Client Plug-Ins indique que le déploiement a échoué.

Échec du déploiement

Dans le menu vSphere Client Administration > Solutions > Client Plug-Ins, le déploiement a échoué en raison d’une exception de sécurité Java.  
Error downloading plug-in. Make sure that the URL is reachable and the registered thumbprint is correct. sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target sun.security.provider.certpath.SunCertPathBuilder.build(SunCertPathBuilder.java:141)
 
 
 
 
 
 

Cause

Sur le vCenter Server, les logs HTML5 de vSphere Client affichent le message suivant : « Server certificate chain is not trusted and thumbprint doesn’t match. »   

/var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log :
[2021-03-22T18:39:59.381Z] [INFO ] vc-extensionmanager-pool-207 70000151 100020 200002 com.vmware.vise.vim.extension.VcExtensionManager Downloading plugin package from https://ave194.example.lab/mc/lib/aui.zip (no proxy defined) [2021-03-22T18:39:59.403Z] [ERROR] vc-extensionmanager-pool-207 70000151 100020 200002 com.vmware.vise.vim.extension.PluginStatusTaskManager DOWNLOAD_FAILED: Error downloading plugin package com.dell.emc.avamar:19.4.116 from https://ave194.example.lab/mc/lib/aui.zip. Reason: Download error. Make sure that the URL is reachable and the thumbprint is correct. javax.net.ssl.SSLHandshakeException: com.vmware.vim.vmomi.client.exception.VlsiCertificateException: Server certificate chain is not trusted and thumbprint doesn't match 

Cette erreur explique que le téléchargement du package « aui.zip » à partir d’avamar.example.lab a été abandonné en raison d’une erreur de correspondance de l’empreinte du certificat. 

Le logiciel vSphere Client sur vCenter ne télécharge PAS de package client si le certificat du serveur Avamar distant ne correspond pas à l’empreinte (digitale) du certificat distant du plug-in inscrit. 

1. Pour afficher la liste et le paramètre d’extension du vCenter inscrit à partir d’un navigateur Web, connectez-vous à la page du navigateur d’objets géré par vCenter :  (Le nom d’utilisateur et le mot de passe de l’administrateur sont obligatoires) 
https://vcenter.example.com/mob/?moid=ExtensionManager&doPath=extensionList

2. Recherchez le plug-in Dell EMC Avamar sur cette page   et passez en revue la section « server » de cette extension.  Vous devez obtenir quelque chose de similaire à cet exemple : 
 
NOM TYPE VALEUR
server ExtensionServerInfo[]
NOM TYPE VALEUR
company string « Dell EMC »
description Description
NOM TYPE VALEUR
libellé string "aui"
summary string "Dell EMC Avamar Plugin"
serverThumbprint string "40:79:74:0E:5E:A8:75:F0:9B:1E:59:70:4A:DA:27:A1:E5:9E:61:68"
type string "HTTP"
url string "https://ave194.example.lab/mc/lib/aui.zip"


3.  Pour comparer « serverThumbprint » au paramètre actuel d’Avamar Server, exécutez la commande suivante sur la session SSH de vCenter Server.  Cette commande permet d’établir une connexion HTTPS à Avamar et d’obtenir l’empreinte SSL.  
root@vc6-avamar [ ~ ]# keytool -printcert -sslserver ave194.example.lab:443 -rfc | openssl x509 -fingerprint -noout SHA1 Fingerprint=65:E2:B0:FD:2C:F4:6C:B5:C8:57:08:D0:B9:A6:61:EE:4D:84:48:6E 

Dans cet exemple, l’empreinte 40:79:74:0E:5E:A8:75:F0:9B:1E:59:70:4A:DA:27:A1:E5:9E:61:68  ne correspond PAS à 65:E2:B0:FD:2C:F4:6C:B5:C8:57:08:D0:B9:A6:61:EE:4D:84:48:6E

Resolution

Solution n° 1 (Renouveler l’inscription de l’extension)  
1. Dans le menu Avamar AUI > Administration > System > VMware Plugin, sélectionnez le vCenter, puis choisissez l’action Unregister. 

Sélectionnez Unregister.


2. Vérifiez le navigateur d’objets géré par vCenter pour voir si l’extension « com.dell.emc.avamar » a disparu.
https://vcenter.example.com/mob/?moid=ExtensionManager&doPath=extensionList

Si elle est toujours présente, accédez à la page ci-dessous et saisissez la clé indiquée :   com.dell.emc.avamar. Cliquez ensuite sur Invoke method.  
https://vcenter.example.lab/mob/?moid=ExtensionManager&method=unregisterExtension


3.  Dans le menu Avamar AUI > Administration > System > VMware Plugin, sélectionnez le vCenter, puis choisissez l’action Register.     

4.  Vérifiez le navigateur d’objets géré par vCenter pour voir si l’extension « com.dell.emc.avamar » serverThumbprint a MAINTENANT été rajoutée. .  
https://vcenter.example.com/mob/?moid=ExtensionManager&doPath=extensionList

5.  Déconnectez-vous et reconnectez-vous pour vérifier si le plug-in est MAINTENANT installé

REMARQUE : Si serverThumbprint est toujours incorrect, cela peut indiquer la présence d’un routeur NAT entre vCenter et Avamar ou un problème au niveau du logiciel Avamar.     

Contactez le support Dell EMC et consultez l’article 000184447 de la base de connaissances si aucun routeur NAT n’est présent ou si le problème nécessite une procédure d’enquête plus approfondie.  


SINON 
Solution n° 2 Installer manuellement le plug-in.   (nécessite un accès root à vCenter)

1. Connectez-vous en SSH au serveur vCenter et exécutez les commandes suivantes pour télécharger aui.zip à l’emplacement de vCenter Server qui convient et avec les autorisations appropriées.   
cd /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/ mkdir com.dell.emc.avamar-19.4.116 cd com.dell.emc.avamar-19.4.116 wget  --no-check-certificate  https://ave194.example.lab/mc/lib/aui.zip  unzip aui.zip   chown -R vsphere-ui:users ../com.dell.emc.avamar-19.4.116
REMARQUE : remplacez « 19.4.116 » par la version actuelle du plug-in et « ave194.example.lab » par le nom de l’Avamar Server.  

2. Déconnectez-vous et reconnectez-vous pour vérifier si le plug-in est MAINTENANT installé


le plug-in est visible après une actualisation

3.  Après avoir cliqué sur Refresh Browser, le plug-in est désormais visible dans le menu Home :

Le plug-in Dell s’affiche

Affected Products

Avamar

Products

Avamar Client for VMware
Article Properties
Article Number: 000184447
Article Type: Solution
Last Modified: 11 Aug 2022
Version:  5
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