My Dell Presence Detect Tile Missing on XPS 9320 and XPS 9315

Summary: This article discusses how to resolve My Dell Presence Detect tile missing on the XPS 9320 and XPS 9315.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Platforms:

  • XPS 9320
  • XPS 9315

Step to reproduce this issue:

  1. Reimage one of these computers.
  2. Install My Dell from the Microsoft store.
  3. Go to the home page of My Dell application.
  4. Follow the on-screen prompts to install the missing fusion service component and accept the User Account Control (UAC) prompt.

Cause

My Dell 2.0 and above enables the Presence Detection feature on these XPS models, but if they had to reimage the machine for any reason, they would see Presence Detect tile missing in the home page in the first launch if they do not reinstall the My Dell and its components in the right order. If they run into this issue, they must relaunch the application.

Resolution

How to install My Dell and its dependencies in the right order

  1. Install Fusion service from the affected platforms page on dell.com.
  2. Ensure the fusion service and Intel Context Sensing Technology (ICST) service is in running state.
  3. Install My Dell from the Microsoft store.

Affected Products

MyDell, XPS 13 9315, XPS 13 Plus 9320
Article Properties
Article Number: 000205244
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  5
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