Avamar: Proxy Deployment Manager - New Proxy Fails to Deploy Due to Locked File Error
Summary: Avamar: Proxy Deployment Manager - New Proxy Fails to Deploy Due to "Error Powering on Proxy: Unable to Access File Since It Is Locked"
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Symptoms
The deployment of new proxies in VSAN environments using Proxy Deployment Manager may fail due to the following.
Error Message: "Error powering on proxy: Unable to access the file since it is locked."
Log Location: This error appears in the following log file on the Avamar server:
/usr/local/avamar/var/log/vcs/deploymanager.log
Log Details:
TRACE [Thread-39 ][ impl.ConnectionManagerService# releaseSession]: Releasing connection manager session: id=...147079090986 DEBUG [Thread-39 ][ worker.DeployWorker# run]: Powering on VM TRACE [Thread-40 ][ util.VcConnection# keepAlive]: Keep-aliving VC session TRACE [Thread-40 ][ impl.ConnectionManagerService# sendKeepAlive]: Keep-alive connection manager session: ...85fdd16e4831 WARN [Thread-39 ][ worker.DeployWorker# run]: Error powering on proxy: Unable to access file since it is locked WARN [Thread-39 ][ worker.DeployWorker# run]: Uncaught MethodFault null DEBUG [Thread-39 ][ worker.TaskWorker#teTaskDescription]: Updating task description: INFO [Thread-39 ][ worker.TaskWorker# sendTaskError]: Sending fault com.vmware.vim25.LocalizedMethodFault@60a82b15 INFO [Thread-39 ][ worker.DeployWorker# run]: Deploy of proxy gnewproxyhostname.example.com (19.10.100-166) to host esxi.example.com was not successful. Cleaning up deploy artifacts... DEBUG [Thread-39 ][ worker.TaskWorker#teTaskDescription]: Updating task description: Cleaning up after error... INFO [Thread-39 ][ worker.DeployWorker# run]: keepDeployFailedProxy: false
Cause
The file locking issue is due to:
- Environmental factors; this problem does not occur in most environments.
- Insufficient delay between the failed power-on attempt and the manual power-on
- Timing issues that make it difficult to determine the exact cause.
Resolution
Long-term Solution
Hotfixes addressing this issue will be released in AV19.9 and AV19.10SP1. The fix will also be in the next major Avamar release.
Workaround
Contact Dell Support to install a modified version of the Deployment Manager that adds a delay between the deployment task and the power-on task.
Affected Products
AvamarArticle Properties
Article Number: 000233945
Article Type: Solution
Last Modified: 29 Nov 2024
Version: 4
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