PowerProtect Data Manager: Unable to perform Instant Access Restore or File level Restore for a VM. Error ARV0007....
Summary: PPDM Instant Access Restore and File Level Restore fails with error code ARV0007: VM Direct engine is unable to restore the virtual machine 'unknown' on vCenter 'unknown'.
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Symptoms
Unable to restore VM using Instant Access Restore or File Level Restore. PPDM UI shows the following error:
vmdm.log has the following error message:
esxi host does not have any NFS mounted volumes. Also, the vCenter server is 'unknown' in the error message.
ARV0007: VM Direct engine is unable to restore the virtual machine 'unknown' on vCenter 'unknown'. Restore of this virtual machine to the destination vCenter was unsuccessful. Review the error details and summary log in the Jobs window, or export the job logs and review the log files for more information. If the issue persists, contact Dell Customer Support. Read Less Limitation of NFS volumes is exceeded on esx01.mylab.local
vmdm.log has the following error message:
YY-MM-DDThh:mm:ss ERROR [] [request-dispatch-service-1] [][][][][] [c.e.b.v.s.VcenterUtils.getAvailableNfsVolumeForProxy(299)] - Fail to get Available NFS volumes for 150c0545-e231-532d-9389-3344e6db0882: {}
org.springframework.web.client.HttpServerErrorException$InternalServerError: 500 : "{"code":500,"reason":null,"remediation":null,"timestamp":1699303523428,"path":"/api/v2/vmwareservice/vcenters/7508974f-142f-37a3-8651-e7e302984571/
esxi host does not have any NFS mounted volumes. Also, the vCenter server is 'unknown' in the error message.
Cause
Unknown Possible memory corruption of PPDM services.
Resolution
1. ssh into ppdm server as 'admin' user
2. Restart the following services:
NOTE: Prior to restarting the above services, ensure that there are no active backups running. Restarting these services when the backups are running will cause the backups to be cancelled.
2. Restart the following services:
vmdm restart vmware-service restart discovery-service restart3. Give it a few minutes for the services to fully startup and then retry the Instant Access Restore/ File level Restore.
NOTE: Prior to restarting the above services, ensure that there are no active backups running. Restarting these services when the backups are running will cause the backups to be cancelled.
Affected Products
PowerProtect Data ManagerArticle Properties
Article Number: 000219364
Article Type: Solution
Last Modified: 16 Nov 2023
Version: 1
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