Cyber Recovery NetWorker recovery failed with Unable to assign device to pool error

Summary: Cyber Recovery NetWorker recovery failed with Unable to assign device to pool error.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

In the CyberRecovery (CR) UI, after recovery of NetWorker was run, it failed with Unable to assign device to pool error. NetWorker error is please unmount device `<device_name> before removing it from pool `<pool_name>.'

NW recoverapp job failed with error "Unable to assign device to pool"

The following errors can be observed from the logs:

[2021-07-03 22:08:58.906] [ERROR] [apps] [appsUtils.go:121 HandleNWResponse()] : Error response is : {Message:please unmount device `<device_name>  before removing it from pool `<pool_name>.. Status:{Code:400 Class:Client Error Reason:Bad Request}}
[2021-07-03 22:08:58.906] [ERROR] [apps] [RecoverNetWorkerApp.go:657 NWSetPoolNames()] : Unable to assign device to pool. NetWorker Error is please unmount device `<device_name> before removing it from pool `<pool_name>.
[2021-07-03 22:08:58.907] [ERROR] [apps] [RecoverNetWorkerApp.go:150 RunNWWorkflow()] : Found error running task 60- Set NW Pool Names to DD Devices Error was: Unable to assign device to pool. NetWorker Error is please unmount device `<device_name> before removing it from pool `<pool_name>.

 

 

Cause

After nsrdr runs, some of the volumes restored are not unmounted. When CR tries to rename the pool name, the pool is in use.

Resolution

The fix is included in CR 19.8.0.2 and later versions. Upgrade CR to fix this issue. 

Affected Products

PowerProtect Cyber Recovery
Article Properties
Article Number: 000189942
Article Type: Solution
Last Modified: 16 Sept 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.