PowerStore: Dell SupportAssist database may fill up and lead /cyc_node/ (an internal partition) to be full, causing either NDU failure or Node reboot

Summary: PowerStore appliances connected to SupportAssist may experience scenarios where the SupportAssist database (db) grows too large which can interfere with the ability to perform upgrades. ...

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Symptoms

PowerStore appliances connected to SupportAssist may experience an issue where the SupportAssist database (db) grows too large.
This may result in space issues on one of the internal partitions (/cyc_node), which can interfere with the ability to perform upgrades or lead to a node reboot.

This issue may occur on clusters that have an unusually large number of alerts, which causes the db to become too large.
Attempts to upgrade the PowerStoreOS fail with an error suggesting that there is not enough space on /cyc_node to proceed with the upgrade.

Cause

SupportAssist creates a database entry for every file that is uploaded to SupportAssist, and does not have a mechanism for aging those entries out. If the system generates many alerts, the database can grow quickly.

Example command outputs:

[SVC:service@*******-* ~]$ df -hT /cyc_node
Filesystem     Type  Size  Used Avail Use% Mounted on
/dev/md106     ext4  738M  497M  189M  73% /cyc_node    


And

[SVC:service@*******-* ~]$ ls -lh /cyc_node/service/eve/hostmnt_config/opt/ese/var/run/ese/ese.db
-rw-r--r-- 1 1100 1001 200M Sep 21 21:04 /cyc_node/service/eve/hostmnt_config/opt/ese/var/run/ese/ese.db      

 

Common scenarios linked to this alert are as follows and are addressable with the svc_partition_cleanup service script:

 

Resolution

The vast majority of causes leading to partition full conditions have been resolved in PowerStoreOS LTS-v4.1.x.

After resolving the current condition, update the PowerStore Appliance to PowerStoreOS LTS-v4.1.x or higher.

WORKAROUND:

NOTE: This is only a temporary, plan to upgrade to PowerStoreOS 3.2.1.0 and above, as soon as possible.

Cycle the SupportAssist feature to clear out extraneous files on the /cyc_node mount.

  1. From the PowerStore UI, go to Settings > Support Connectivity > Connection Type
  2. Take note of the configuration displayed as the details must be reentered in a later step
  3. Click to Disabled
  4. Click Apply at the bottom of the page
  5. Once the job appears to have finished, refresh the UI page to verify the feature is disabled
    1. If it does show disabled after a refresh of the UI page, continue to step 2
    2. If it remains enabled after two attempts, contact Dell Technical Support or your Authorized Service Representative, and reference this article ID
  6. Wait 15 minutes
  7. Enable SupportAssist with the original configuration details captured earlier
  8. Once the job appears to have finished, refresh the UI page to verify the feature is enabled
  9. If the issues persist utilize the svc_partion_cleanup service script to investigate and clean up the root partitions

 

If the issues persist or return, contact Technical Support for assistance. 

Reference KB# 000202949 for expedited service.

Additional Information

Affected Products

SupportAssist, PowerStore
Article Properties
Article Number: 000202949
Article Type: Solution
Last Modified: 20 Nov 2025
Version:  10
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