Dell NativeEdge: Upload token with "cannot decode token" error

Summary: Upload token with "cannot decode token" error on NativeEdge Orchestrator.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After May 29, 2025, if users try to generate a new access token from Dell Digital Locker (or as "My Account") and upload to existing NativeEdge Orchestrator, users will observe "cannot decode token" error on the orchestrator user interface.
Cannot decode token error 

 

Cause

This is due to an unexpected backend change from Dell Digital Locker.

The header and footer should be below strings.

-----BEGIN EDGE ORCHESTRATOR ACCESS TOKEN-----

-----END EDGE ORCHESTRATOR ACCESS TOKEN-----

Instead, it shows up as below strings.

-----BEGIN ACCESS TOKEN-----

-----END ACCESS TOKEN-----

Resolution

NativeEdge engineering is aware of the issue and works with the Dell Digital Locker side to revert the changes.

This KB is updated once the header and footer is reverted back to the correct format.

The only workaround is to use air-gapped method to upload VOUCHERS. 

Note Replacing the incorrect format of header and footer with the correct format of header and footer do not allow the access token to pull vouchers from Dell Digital Locker as it does not recognize the modified access token. 

Update on Jun 18

Dell Digital Locker side reverted the changes and newly-created access tokens are working properly. Access tokens generated between May 29 - Jun 18 are broken. Advise customers to generate new tokens from My Account. 

Affected Products

NativeEdge Solutions
Article Properties
Article Number: 000333293
Article Type: Solution
Last Modified: 23 Jun 2025
Version:  2
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