NetWorker: Email Notification not triggered when a device is unmounted
Summary: A notification has been configured in NetWorker would send an email when a device unmount is performed; however, no email messages are received.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- NetWorker server is 19.7.1.1 or below.
- An email notification has been configured in NetWorker with the following criteria:
Event: Media, Device Disabled, Data Domain, Device Disabled 2, Bus/Device Reset, Volume Scan Needed
Priority: Warning, Critical, Alert, Emergency
Action: Email_command
Priority: Warning, Critical, Alert, Emergency
Action: Email_command
Linux:
/bin/mail -S MAILHOST_ADDRESS -s "SUBJECT" -r SENDER_ADDRESS@EMAIL RECIPIENT_ADDRESS@EMAILWindows:
smptmail -h MAILHOST_ADDRESS -s "SUBJECT" -f SENDER_ADDRESS@EMAIL RECIPIENT_ADDRESS@EMAIL
- A device is unmounted in NetWorker, and the following is logged in the NetWorker server's daemon.raw:
MM/DD/YYYY HH:MM:SS 2 0 0 387454784 3058914 0 NSR_SERVERNAME nsrd NSR warning DEVICE_NAME unmounted VOLUME_NAME.###
NOTE: The unrendered daemon.raw can be rendered with the following command: NetWorker: How to use nsr_render_log to render .raw log files
- No email was received notifying the recipient that a device was unmounted.
- No mail functionality issue is observed. All other configured email notifications are being received from the NetWorker server.
Cause
This is expected behavior.
Resolution
Enhancements were added to NetWorker 19.8.
NOTE: NetWorker 19.7 is end of support as of 2025-06-30. NetWorker 19.8 is end of support as of 2025-11-30.
Supported NetWorker releases can be downloaded from: https://www.dell.com/support/home/product-support/product/networker/drivers
Version end-of-life dates can be found in the Overview tab.
The notification can be configured from the NetWorker Management Console (NMC) under Server->Notifications. The notification requires to the following:
Event:
Media, Device Disabled, Data Domain, Device Disabled 2, Bus/Device Reset, Volume scan needed.
Priority:
Warning, Critical, Alert, Emergency
Action: user specified mail command.
Linux:
/bin/mail -S MAILHOST_ADDRESS -s "SUBJECT" -r SENDER_ADDRESS@EMAIL RECIPIENT_ADDRESS@EMAILWindows:
smptmail -h MAILHOST_ADDRESS -s "SUBJECT" -f SENDER_ADDRESS@EMAIL RECIPIENT_ADDRESS@EMAIL
Additional Information
For information about configuring notifications see the NetWorker Administration Guide available through https://www.dell.com/support/home/product-support/product/networker/docs
NetWorker: How to troubleshoot failing email notifications
NetWorker: How To Configure Policy Email Notifications
Products
NetWorker Family, NetWorkerArticle Properties
Article Number: 000202778
Article Type: Solution
Last Modified: 30 Oct 2025
Version: 4
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