NetWorkerはWindows上でNMCパッケージをアップグレード/インストールできません。

Summary: NetWorkerサーバーのアップグレードは成功しますが、プロセスでnmcがアップグレードされず、アンインストールされてしまいます。個別にインストールしようとしても失敗します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 
  • NetWorkerサーバーはアップグレードできますが、NetWorker管理コンソール(NMC)はアップグレードできません。 
  • ..\Program Files\EMC NetWorker\Managementフォルダーの名前が変更されて、MetWorker管理コンソールの新規インストールができません。
  • インストール ログのエラー:
[0DE4:08FC][2020-01-20T21:21:59]i000: nsrd : StartService failed.
Error Code = 1056.
Error Message :
An instance of the service is already running.
  • NMCのレジストリー エントリーを削除しようとしても、問題は解決しません。

Cause

古いNMCは、レジストリー エントリーの形式でマシン上に存在しています。

Resolution

Microsoftプログラムのインストールおよびアンインストール ツールをインストールする必要があり、NMCインストールの古いファイルを削除します。

Microsoftのリンク(外部:https://support.microsoft.com/en-us/help/17588/windows-fix-problems-that-block-programs-being-installed-or-removed
パッケージ名:MicrosoftProgram_Install_and_Uninstall.meta.diagcab.
タグ:プログラムのインストールまたは削除がブロックされる問題を解決する。

手順:
1.サーバーからMicrosoftProgram_Install_and_Uninstall.meta.diagcabを実行します。
2.[Fix installation issues]をクリックします。
     表示されるアプリケーションのリストに「NetWorker Management Console」があります。
3.「NetWorker Management Console」を選択して、[fix]ボタンをクリックします。
4.成功したら、もう一度ツールを実行して、再度表示されるかどうかを確認できます。
5.これで、パッケージのインストールを続行できるようになりました。

Additional Information

NMCの古いファイルを削除するには、NetWorkerパッケージのアンインストールが必要な場合があります。このような場合、res、mm、インデックスをコピーしておくことをお勧めします。そうすれば、同一ディレクトリーに再インストールした後に設定が失われても、元に戻すことができます。

インストール ウィザードからNMCを設定する場合、nmcdbが保存されるようにnmcdbへのパスを選択できます。

このコンテンツは15か国語に翻訳されています。 
https://downloads.dell.com/TranslatedPDF/CS_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/DA_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/DE_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/FI_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/FR_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/IT_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/JA_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/KO_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/NL_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/NO-NO_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/PL_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/RU_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/SV_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/TR_KB540402.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_KB540402.pdf

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000063511
Article Type: Solution
Last Modified: 07 May 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.