NVP vProxy: Application consistent backup fails with an error quiescing the VM
Summary: NetWorker VMware Protection (NVP) is configured to protect Microsoft SQL Virtual Machines (VM) using application consistency (MSVMAPPAGENT). The backup fails to create a quiesced snapshot of the VM. ...
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Symptoms
- NetWorker VMware Protection (NVP) is configured to protect Microsoft SQL VMs using application consistency (MSVMAPPAGENT).
- The backup fails to create a quiesced snapshot of the VM. An error appears, stating:
Failed to get status of create snapshot task: An error occurred while quiescing the virtual machine. See the virtual machine's event log for details.
- Standard image backups that perform nonquiesced snapshot (No Application Consistency) succeeds without issue.
NOTE: SQL VM backups use "quiesce snapshot" to perform application consistency on the VM. If the VM is not a SQL VM, then quiesced snapshots should not be used. Similar errors may be observed while performing a quiesced snapshot of the VM directly from VMware.
Cause
This issue is occurring outside of NetWorker.
NetWorker VMware Protection (NVP) uses VMware snapshot functionality to create a quiesced snapshot (app consistent) backup of the Virtual Machine (VM).
The issue may appear after automatic upgrade of VMware Tools, or corrupted VMware Tools install on the VM.
NetWorker VMware Protection (NVP) uses VMware snapshot functionality to create a quiesced snapshot (app consistent) backup of the Virtual Machine (VM).
The issue may appear after automatic upgrade of VMware Tools, or corrupted VMware Tools install on the VM.
Resolution
- On the SQL VM, check the C:\ProgramData\VMware\VMware Tools\vmtoolsUpgrade.log for any errors or warnings.
- Manually reinstall or repair the installation of VMware Tools, then reboot the VM.
- Enable VMware debugging and check for errors during snapshot creation: https://knowledge.broadcom.com/external/article?legacyId=1007873
NOTE: This KB provides some general recommendations; however, for any detailed analysis or resolving of VMware snapshot issues, engage VMware support.
Additional Information
In one example the following was observed in the VM's vmware.log after enabling 1007873 debug.
2017-06-18T12:16:35.834Z| vcpu-0| I125: Guest: [ debug] [vmsvc:vmsvc] RpcIn: received 155 bytes, content:"(assumed/dropped binary data)"
2017-06-18T12:16:35.834Z| vcpu-0| I125: Guest: [ debug] [vmsvc:vmbackup] *** VmBackupStartWithOpts
2017-06-18T12:16:35.835Z| vcpu-0| I125: Guest: [ debug] [vmsvc:vmsvc] VMTools_ConfigGetBoolean: Returning default value for '[vmbackup] vssUseDefault'=FALSE.
2017-06-18T12:16:35.835Z| vcpu-0| I125: Guest: [ debug] [vmsvc:vmsvc] VMTools_ConfigGetBoolean: Returning default value for '[vmbackup] forceQuiesce'=TRUE.
2017-06-18T12:16:35.836Z| vcpu-0| I125: Guest: [ debug] [vmsvc:vmsvc] VMTools_ConfigGetBoolean: Returning default value for '[vmbackup] enableVSS'=TRUE.
2017-06-18T12:16:35.837Z| vcpu-0| I125: Guest: [ warning] [vmsvc:vmbackup] Requested quiescing cannot be initialized.
2017-06-18T12:16:35.837Z| vcpu-0| I125: Guest: [ debug] [vmsvc:vmsvc] RpcIn: sending 43 bytes
2017-06-18T12:16:35.837Z| vcpu-0| I125: Msg_Post: Warning
2017-06-18T12:16:35.837Z| vcpu-0| I125: [msg.snapshot.quiesce.startfail] Failed to start quiescing operation in the virtual machine.
2017-06-18T12:16:35.837Z| vcpu-0| I125+ The error message was: Error initializing quiesce operation.
2017-06-18T12:16:35.837Z| vcpu-0| I125: ----------------------------------------
2017-06-18T12:16:35.839Z| vcpu-0| I125: ToolsBackup: changing quiesce state: IDLE -> DONE
2017-06-18T12:16:35.839Z| vcpu-0| I125: SnapshotVMXTakeSnapshotComplete: Done with snapshot 'NetWorker Backup Snapshot': 0
2017-06-18T12:16:35.839Z| vcpu-0| I125: SnapshotVMXTakeSnapshotComplete: Snapshot 0 failed: Failed to quiesce the virtual machine (29).
2017-06-18T12:16:35.839Z| vcpu-0| I125: VigorTransport_ServerSendResponse opID=6d6fe57e-72-4550 seq=187250: Completed Snapshot request.
After reinstalling VMware Tools manually and restarting the Guest VM, the backup started working properly..
Affected Products
NetWorkerProducts
NetWorker FamilyArticle Properties
Article Number: 000023919
Article Type: Solution
Last Modified: 11 Aug 2025
Version: 4
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