ECS: GeoDrive: Error: 12029 - A connection with the server could not be established
Summary: GeoDrive Error: 12029 - "A connection with the server could not be established" while adding ECS to GeoDrive client.
Symptoms
When adding an ECS to GeoDrive Windows client per the user guide, you might see an error message during connection testing after adding the IP:
Error: 12029 - A connection with the server could not be established
Cause
The Windows or GeoDrive Client is unable to connect to ECS.
Resolution
Confirm with the customer if there is a Load Balancer (LB) in use or if connection is made directly to ECS nodes.
Use tools like telnet for testing the connection from Windows client to ECS data IP port 9020 (HTTP) / 9021 (HTTPS).
If telnet is not enabled on the customer's Windows client, ask to temporarily enable (Windows features) or use a client on the same subnet.
Example:
C:\>telnet 10.1.1.1 9021 Connecting To 10.1.1.1...Could not open connection to the host, on port 9021: Connect failed C:\>
If no connection is possible the following steps should be checked:
- The customer would need to ensure, the required port is not blocked on a firewall in the customer environment.
- The correct ECS IP address is used. Ensure that the data IP address is used in case network separation is enabled on ECS side and not the management IP.
Connect to ECS and verify if there is network separation enabled and examine the data IP address:
Example:
admin@ecs1:~> getrackinfo -n Named networks ============== Node ID Network Ip Address Netmask Gateway VLAN Interface 1 repl 10.1.1.211 255.255.255.0 10.1.1.201 16 public 1 data 10.1.2.202 255.255.255.0 10.1.2.201 123 public 2 repl 10.1.1.212 255.255.255.0 10.1.1.201 16 public 2 data 10.1.2.203 255.255.255.0 10.1.2.201 123 public 3 repl 10.1.1.213 255.255.255.0 10.1.1.201 16 public 3 data 10.1.2.204 255.255.255.0 10.1.2.201 123 public 4 repl 10.1.1.214 255.255.255.0 10.1.1.201 16 public 4 data 10.1.2.205 255.255.255.0 10.1.2.201 123 public 5 repl 10.1.1.215 255.255.255.0 10.1.1.201 16 public 5 data 10.1.2.206 255.255.255.0 10.1.2.201 123 public
In above example IPs 10.1.2.202 - 206 would be correct and needed to be used for the GeoDrive client configuration.
The below logfile eventually can help to further troubleshoot by searching for the Windows Client IP address inside this file. (in the above case no connection attempt shows there, as datahead is not getting any connection): /opt/emc/caspian/fabric/agent/services/object/main/log/dataheadsvc.log
You can also use svc_log for searching through all dataheadsvc.logs across all nodes for the Windows Client IP address:
admin@ecs1:~> svc_log -f '10.x.x.x' -sr dataheadsvc -n all -sn -sf
Additional Information
The same error can appear if the user's credentials are configured wrongly.
1. The user ID should be an Object User.
2. The Secret Access Key should be the S3 key generated for the object user.
You can edit the User ID and The Secret Access Key as per the following steps from GeoDrive:
Press on "add GeoDrive" >> Hosts >> Press on the Host you want to edit >> Edit