Avamar : La restauration du système de fichiers Windows échoue avec les messages « Impossible de sauvegarder l’écriture » et « Les données ne sont pas valides »
Summary: La restauration du système de fichiers Windows échoue avec des erreurs : Avtar Error <5737>: E/S et erreur : Impossible de BackupWrite(4) « D:Temp_file_name_.xlsx » (code 13 : Les données ne sont pas valides). Cet article traite du problème « code 13 : Les données ne sont pas valides » qui peut s’afficher lors d’une opération de restauration Avamar. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
La tâche de restauration de certains fichiers .xlsx et .pdf échoue avec les erreurs suivantes dans le fichier log :
2017-01-18 11:34:54 avtar Error <5737>: I/O error: Unable to BackupWrite(4) "D:\Temp\_file_name_.xlsx" (code 13: The data is invalid). 2017/01/18-10:34:54.05100 [avtar] restdata: BackupRead content is valid 2017-01-18 11:34:54 avtar Error <5189>: Error restoring path "D:\aaaaa\bbbbbb\cccccc\xxxx\_file_name_.xlsx" to "D:\Temp\". 2017-01-18 11:34:54 avtar Error <5263>: Restore of "D:\aaaaa\bbbbbb\cccccc\xxxx\_file_name_.xlsx" failed
Les fichiers concernés sont restaurés, mais Excel ou Acrobat Reader ne peuvent pas les ouvrir car ils semblent corrompus.
Exemple de message d’erreur lors de la tentative d’ouverture du fichier :
"Excel cannot open the file 'filename.xlsx' because the file format for the file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file."
Les autres fichiers .xlxs ou .pdf de la même tâche de restauration sont restaurés et peuvent être ouverts.
Cause
Ce comportement est dû à une combinaison de fichiers restaurés avec des en-têtes de fichier, NTFS et FAT32 différents, vers une partition NTFS par la même tâche de restauration.
Les fichiers mentionnés dans les avertissements ont un en-tête de fichier FAT32. Ces fichiers ont été créés sur un ancien serveur Windows 2003 avec des partitions FAT32, puis déplacés vers un système avec des partitions NTFS.
Les fichiers mentionnés dans les avertissements ont un en-tête de fichier FAT32. Ces fichiers ont été créés sur un ancien serveur Windows 2003 avec des partitions FAT32, puis déplacés vers un système avec des partitions NTFS.
Resolution
Ce problème a été identifié comme un problème de code dans le fichier binaire avtar et il a déjà été résolu. Les versions actuelles d’Avamar ne devraient pas rencontrer ce problème.
Si le problème se produit sur l’une des versions actuelles d’Avamar, il peut être contourné en procédant comme suit :
Si le problème se produit sur l’une des versions actuelles d’Avamar, il peut être contourné en procédant comme suit :
- Avant l’opération de restauration, ajoutez la balise
--x06=4096dans le fichier avtar.cmd dans le chemin de l’agent<client-install-folder>\var. - Exécutez la restauration de ces fichiers FAT32, puis supprimez la balise après la restauration.
Remarque :
- La balise a été conçue pour restaurer des fichiers avec des en-têtes FAT32 sur une partition NTFS.
- Cette balise ne peut être utilisée que pour les types de fichiers FAT32 et ne parvient pas à restaurer les types de fichiers NTFS.
- Une fois la restauration du fichier FAT32 terminée, la balise doit être supprimée du fichier avtar.cmd et réutilisée uniquement lorsque cela est nécessaire.
Affected Products
AvamarProducts
Avamar, Avamar Client for WindowsArticle Properties
Article Number: 000054812
Article Type: Solution
Last Modified: 09 Oct 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.