Avamar: Systemgjenoppretting av Windows mislykkes med "Unable to BackupWrite" og "The data is invalid"

Summary: Systemgjenoppretting av Windows-filer mislykkes med feil: Avtar-feil <5737>: I/O og feil: Unable to BackupWrite(4) "D:Temp_file_name_.xlsx" (kode 13: Dataene er ugyldige). Denne artikkelen omhandler problemet "code 13: Dataene er ugyldige" som kan vises under en Avamar-gjenopprettingsoperasjon. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Gjenopprettingsjobben for enkelte .xlsx- og .pdf-filer mislykkes med følgende feil i loggfilen:
2017-01-18 11:34:54 avtar Error <5737>: I/O error: Unable to BackupWrite(4) "D:\Temp\_file_name_.xlsx" (code 13: The data is invalid).
2017/01/18-10:34:54.05100 [avtar]  restdata: BackupRead content is valid
2017-01-18 11:34:54 avtar Error <5189>: Error restoring path "D:\aaaaa\bbbbbb\cccccc\xxxx\_file_name_.xlsx" to "D:\Temp\".
2017-01-18 11:34:54 avtar Error <5263>: Restore of "D:\aaaaa\bbbbbb\cccccc\xxxx\_file_name_.xlsx" failed

De berørte filene gjenopprettes, men Excel eller Acrobat Reader kan ikke åpne filene fordi de ser ut til å være skadet.

Eksempel på en feilmelding når du prøver å åpne filen:

"Excel cannot open the file 'filename.xlsx' because the file format for the file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file."

Andre XLX- eller .pdf-filer fra samme gjenopprettingsjobb gjenopprettes og kan åpnes.

Cause

Dette problemet skyldes en kombinasjon av gjenopprettede filer med forskjellige filhoder, NTFS og FAT32, til en NTFS-partisjon med samme gjenopprettingsjobb.

Filene nevnt i advarslene har en FAT32-filoverskrift. Disse filene ble opprettet på en gammel Windows 2003-server med FAT32-partisjoner og deretter flyttet til et system med NTFS-partisjoner.

Resolution

Dette problemet ble identifisert som et kodeproblem i avtar-binærfilen, og det er allerede løst. Dette problemet skal ikke være gjeldende Avamar-versjoner.

Hvis problemet oppstår på noen av de gjeldende Avamar-versjonene, kan du omgå dette trinnet:
  1. Før gjenopprettingsoperasjonen, legg til flagget --x06=4096 i avtar.cmd-filen i agentbanen <client-install-folder>\var.
  2. Kjør gjenopprettingen av disse FAT32-filene, og fjern deretter flagget etter gjenopprettingen.
 
Merk:
  • Flagget ble utformet for å gjenopprette filer med FAT32-hoder til en NTFS-partisjon.
  • Dette flagget kan bare brukes for FAT32-filtyper og kan ikke gjenopprette NTFS-filtyper.
  • Når gjenopprettingen av FAT32-filen er fullført, må flagget fjernes fra avtar.cmd filen og bare brukes på nytt når det er nødvendig.

Affected Products

Avamar

Products

Avamar, Avamar Client for Windows
Article Properties
Article Number: 000054812
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.