NVP-vProxy: I backup delle VM hanno esito negativo: il proxy NSR VMware non è disponibile per il datastore che utilizza la modalità di trasporto "Hotadd" in vCenter
Summary: L'integrazione NetWorker VMware Protection (NVP) è configurata con l'appliance vProxy. I backup di vProxy hanno esito negativo con errori indicanti che vProxy non è disponibile per i datastore che utilizzano la modalità di trasporto hotadd nel vCenter Server. Questo errore indica che il vProxy o il relativo host ESXi non ha accesso al mounting hotadd della VM non riuscita, che risiede nel datastore elencato nel messaggio di errore. Per risolvere questo problema, il vProxy deve avere accesso al datastore in cui risiede la VM guasta. Ci sono molti modi per farlo. La soluzione più semplice dipende dalla struttura VMware. Verificare che i prerequisiti elencati siano soddisfatti prima di decidere quale opzione sarà la soluzione migliore per il proprio ambiente. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
L'integrazione NetWorker VMware Protection (NVP) è configurata con l'appliance vProxy. I backup di vProxy hanno esito negativo con errori indicanti che vProxy non è disponibile per il datastore che utilizza il trasporto hotadd. Il log delle azioni di backup e NetWorker Management Console mostrano:
NSR VMware proxy is not available for datastores (Datastore name) using transport mode 'Hotadd' in vCenter 'vCenter FQDN'
Cause
Il messaggio di errore indica che un vProxy registrato e online sul server NetWorker non ha accesso al datastore di riferimento. Ciò può essere comunemente causato da diversi motivi:
- Il vProxy potrebbe non avere accesso all'host ESXi in cui risiede la VM di cui viene eseguito il backup.
- L'host ESXi del vProxy potrebbe non avere accesso al datastore in cui risiede la macchina virtuale di cui viene eseguito il backup.
- Il vProxy potrebbe non essere registrato correttamente sul server NetWorker.
- Il server NetWorker e vProxy potrebbero non funzionare correttamente per la risoluzione dei nomi l'uno dell'altro.
- Il vProxy potrebbe non avere accesso all'host ESXi in cui risiede la VM di cui viene eseguito il backup.
- L'host ESXi del vProxy potrebbe non avere accesso al datastore in cui risiede la macchina virtuale di cui viene eseguito il backup.
- Il vProxy potrebbe non essere registrato correttamente sul server NetWorker.
- Il server NetWorker e vProxy potrebbero non funzionare correttamente per la risoluzione dei nomi l'uno dell'altro.
Resolution
Verificare che i seguenti prerequisiti per vProxy siano stati soddisfatti per l'ambiente.
1) Verificare che vProxy possa accedere all host ESXi, sulle porte 443 e 902, dove risiede la macchina virtuale. Queste porte sono necessarie per le operazioni di backup e ripristino.
4) Verificare che vProxy si trovi su un host ESXi con accesso al datastore segnalato nell'errore di backup.
Una volta soddisfatti correttamente i prerequisiti per l'ambiente, le seguenti opzioni dovrebbero facilitare l'accesso al datastore della macchina virtuale per il flusso di lavoro di backup.
1) Verificare che vProxy possa accedere all host ESXi, sulle porte 443 e 902, dove risiede la macchina virtuale. Queste porte sono necessarie per le operazioni di backup e ripristino.
- Da una sessione ssh vProxy, utilizzare il comando curl per convalidare l'accesso: curl -v https://[ESXi_FQDN]:[PORT]
- Passare alla configurazione vProxy accedendo alla scheda "Devices" in NMC e selezionare la sezione VMware vProxies nel menu a sinistra.
- Nel riquadro dei dettagli a destra, cliccare con il pulsante destro del mouse per accedere a "Properties".
- Nella scheda "Configuration" della finestra NSR VMware Proxy Properties il campo VM proxy certificate deve essere compilato.
- Se il certificato non viene popolato, seguire l'articolo della Knowledge Base di Dell per registrare nuovamente il vProxy. NVP vProxy: Come annullare/registrare un appliance vProxy?
4) Verificare che vProxy si trovi su un host ESXi con accesso al datastore segnalato nell'errore di backup.
a) Accedere a vSphere Web Client per vCenter.
b) Accedere alla VM vProxy in VMs and Templates e cliccare sulla scheda Summary.
c) Il campo Related Objects mostra l'host ESXi su cui risiede il vProxy:
b) Accedere alla VM vProxy in VMs and Templates e cliccare sulla scheda Summary.
c) Il campo Related Objects mostra l'host ESXi su cui risiede il vProxy:

d) Andare alla scheda Hosts and Clusters e selezionare l'host ESXi identificato nel passaggio precedente.
e) Cliccare sulla scheda Datastores:
e) Cliccare sulla scheda Datastores:

Il vProxy dispone solo dell'accesso hotadd alle VM che risiedono nei datastore accessibili dall host ESXi in cui risiede il vProxy.
Una volta soddisfatti correttamente i prerequisiti per l'ambiente, le seguenti opzioni dovrebbero facilitare l'accesso al datastore della macchina virtuale per il flusso di lavoro di backup.
- Implementare un vProxy aggiuntivo in un cluster con host ESXi con accesso al datastore di riferimento
- Eseguire uno Storage vMotion della macchina virtuale interessata in un datastore accessibile dall host ESXi che ospita il vProxy
- Aggiornare lo zoning della SAN per garantire che l'host ESXi vProxy abbia accesso al datastore
- Creare un flusso di lavoro e configurare l'azione di backup in modo che utilizzi un solo vProxy. Assicurarsi che nel vProxy siano disabilitate le sessioni di trasporto hotadd e siano abilitate le sessioni di trasporto NBD. Se si utilizza il trasporto NBD come modalità di trasporto di backup principale, si consiglia una rete 10G. L'esecuzione di molti backup con la modalità NBD può causare la congestione sulla rete di gestione dell host ESXi. Pianificare attentamente la rete di backup per installazioni NBD su larga scala
Additional Information
Per ulteriori informazioni sulla connettività vProxy e sulle modalità di trasporto hotadd e NBD, consultare la Guida all'integrazione di NetWorker VMware per la versione di NetWorker in uso: https://www.dell.com/support/home/product-support/product/networker/docs
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000057075
Article Type: Solution
Last Modified: 26 Sep 2023
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.