คําถามที่ถามบ่อยเกี่ยวกับการอัปเดตระบบปฏิบัติการของศูนย์เก็บข้อมูล
Summary: บทความนี้ออกแบบมาเพื่อตอบคําถามที่ถามบ่อยในหัวข้อการปรับปรุงระบบปฏิบัติการศูนย์จัดเก็บข้อมูล (SCOS)
Symptoms
- การอัปเดต SCOS คืออะไร
- การอัพเดตรบกวนหรือไม่?
- ฉันไม่เห็นการปรับปรุงที่พร้อมใช้งานในไคลเอ็นต์การจัดการของฉันใช่หรือไม่
- ฉันสามารถปรับปรุงได้หรือไม่หากฉันไม่มีการเข้าถึงเครือข่ายในสถานที่
- สิ่งที่คาดหวังเมื่อขออัปเดต SCOS?
- ฉันต้องเตรียมอะไรบ้างสําหรับการอัปเดต SCOS
- ฉันจะตรวจสอบกฎไฟร์วอลล์สําหรับ SupportAssist/Secure Console ได้อย่างไร
- ฉันจะทําการทดสอบการล้มเหลวได้อย่างไร
- ฉันจะตรวจสอบแนวทางปฏิบัติที่ดีที่สุดได้ที่ไหน
- การอัปเดตใช้เวลานานแค่ไหน?
- จะเกิดอะไรขึ้นถ้าฉันมีปัญหาในการปรับปรุง
- ฉันจะได้รับการแจ้งเตือนอัตโนมัติเกี่ยวกับ SCOS รุ่นใหม่หรือไม่
- อ่านเพิ่มเติม
Cause
การอัปเดต SCOS คืออะไร
การอัปเดตระบบปฏิบัติการศูนย์จัดเก็บข้อมูล Dell EMC (SCOS) เป็นแพ็คเกจที่มีการอัปเดตล่าสุดทั้งหมดสําหรับระบบจัดเก็บข้อมูลทั้งหมด ซึ่งรวมถึงการปรับปรุงสําหรับ BIOS ของระบบ, ระบบปฏิบัติการ Storage Center, เฟิร์มแวร์ของกล่องหุ้ม, เฟิร์มแวร์ดิสก์และคอมโพเนนต์ระบบอื่นๆ ยืนยันการทดสอบการล้มเหลวตามที่อธิบายไว้ที่นี่เสร็จสมบูรณ์ หรือจะเสร็จสมบูรณ์ก่อนที่การอัปเดตจะเกิดขึ้น
Resolution
การอัพเดตรบกวนหรือไม่?
ไม่ใช่ ในระบบควบคุมคู่ที่มีการกําหนดค่าสภาพแวดล้อมอย่างถูกต้องและได้รับการยืนยันเพื่อจัดการกับการล้มเหลวของคอนโทรลเลอร์ไม่มีการหยุดชะงักของบริการ ไม่ต้องหยุดทํางาน วิธีที่ดีที่สุดคือทําการปรับปรุง SCOS ระหว่างหน้าต่างการบํารุงรักษา
การปรับปรุง SCOS จะถูกนําไปใช้กับตัวควบคุมลูกค้าเป้าหมายก่อน และเมื่อเสร็จสิ้นแล้ว หากไม่แน่ใจถึงความเหมาะสมสําหรับการอัปเดตที่ไม่ก่อกวนโปรดตรวจสอบด้วยการทดสอบการล้มเหลวของคอนโทรลเลอร์ในระหว่างหน้าต่างการบํารุงรักษา รายละเอียดเพิ่มเติมเกี่ยวกับการทดสอบที่แนะนําสามารถดูได้ ที่นี่ .
ฉันไม่เห็นการปรับปรุงที่พร้อมใช้งานในไคลเอ็นต์การจัดการของฉันใช่หรือไม่
ฉันสามารถปรับปรุงได้หรือไม่หากฉันไม่มีการเข้าถึงเครือข่ายในสถานที่
สิ่งที่คาดหวังเมื่อขออัปเดต SCOS?
- ติดต่อฝ่ายสนับสนุนของ Dell EMC เพื่อตรวจสุขภาพ สิ่งนี้ควรทําหนึ่งสัปดาห์ก่อนการอัปเดต SCOS
- ข้อกําหนดก่อนการอัปเดต เช่น การอัปเดต Dell Storage Manager จะถูกระบุโดยฝ่ายสนับสนุนของ Dell EMC และแก้ไขโดยลูกค้าก่อนที่จะมีการนําการอัปเดตไปใช้
- การสนับสนุน Dell EMC จําเป็นต้องทําการตรวจสอบความสมบูรณ์ของระบบก่อนการอัปเดต **(สิ่งนี้จะต้องทํางานภายใน 24 ชั่วโมงหลังจากการอัปเดตเกิดขึ้น)
- การสนับสนุน Dell EMC จะปล่อยแพ็คเกจอัปเดต เวลาดาวน์โหลดปกติสําหรับแพ็คเกจนี้อยู่ระหว่าง 20 ถึง 30 นาที แต่อาจแตกต่างกันไป
- ควรวางระบบในโหมดการบํารุงรักษาก่อนที่จะใช้การอัพเดต
- การอัปเดตจะถูกนําไปใช้ผ่านไคลเอนต์การจัดการที่คุณต้องการโดยเลือกตัวเลือกที่ไม่มีผลต่อบริการเว้นแต่จะมีหน้าต่างการบํารุงรักษาเกิดขึ้น เวลาเสร็จสมบูรณ์โดยประมาณสําหรับการอัพเดตและตัวเลือกการติดตั้งอื่นๆ สามารถดูได้ที่นี่
- การตรวจสอบการอัปเดตโพสต์จะดําเนินการโดย Dell EMC Support เมื่อเราได้รับแจ้งว่าการอัปเดตเสร็จสมบูรณ์
ฉันต้องเตรียมอะไรบ้างสําหรับการอัปเดต SCOS
- แนวทางปฏิบัติที่ดีที่สุดของ Dell EMC คือการเรียกใช้ข้อมูลทั้งหมดก่อนที่จะมีการอัปเดตใด ๆ
- มีการเชื่อมต่อ SupportAssist และ SSH ที่ใช้งานได้สําหรับการตรวจสอบก่อน/หลังของระบบ (โปรดทราบว่าอาจต้องใช้การเปลี่ยนแปลงระบบเครือข่ายโดยละเอียดที่นี่
- มีรุ่นที่ติดตั้งของ Dell Storage Manager เข้ากันได้กับรุ่น SCOS ที่คุณต้องการ เวอร์ชันที่ต้องการจะถูกกําหนดและให้บริการโดยฝ่ายสนับสนุนของ Dell EMC ก่อนที่จะมีการอัปเดต
- ตรวจสอบ ความถูกต้องของแนวทางปฏิบัติ ที่ดีที่สุดปัจจุบันสําหรับสภาพแวดล้อมที่กําหนด รวมถึงการตรวจทานเมทริกซ์ความเข้ากันได้ ของที่เก็บข้อมูล โปรดทราบว่าเป็นความรับผิดชอบของลูกค้าในการดําเนินการตรวจสอบเหล่านี้ การตรวจสุขภาพของเราไม่ทราบถึงสภาพแวดล้อมอย่างเต็มที่และอาจไม่สามารถระบุปัญหาที่เป็นไปได้ทั้งหมด ในกรณีที่เลวร้ายที่สุดความล้มเหลวในการตรวจสอบที่เหมาะสมอาจส่งผลให้เกิดการขัดข้องที่ไม่คาดคิด
- ยืนยันการทดสอบการล้มเหลวตามที่อธิบาย ไว้ที่นี่เสร็จสมบูรณ์ หรือจะเสร็จสมบูรณ์ก่อนที่การอัปเดตจะเกิดขึ้น
- ยืนยัน การจําลองแบบ/ไดรฟ์ข้อมูลสด จะถูกหยุดชั่วคราวตลอดระยะเวลาของการปรับปรุงเพื่อให้แน่ใจว่าการจําลองแบบเหล่านั้นยังคงถูกทําข้อมูลให้ตรงกัน
- หากมีการใช้งาน Live Volumes ที่มีความล้มเหลวอัตโนมัติ โปรดดูข้อกําหนดเฉพาะที่ระบุไว้ ที่นี่ เพื่อให้แน่ใจว่าระบบของคุณเป็นไปตามแนวทางปฏิบัติที่ดีที่สุด การไม่ทําเช่นนั้นอาจส่งผลให้ไดรฟ์ข้อมูลออฟไลน์ระหว่างการปรับปรุง
- ควรปรับปรุงระบบการจําลองแบบภายในหน้าต่างการบํารุงรักษาเดียวกัน
ฉันจะตรวจสอบกฎไฟร์วอลล์สําหรับ SupportAssist/Secure Console ได้อย่างไร
สําหรับตัวควบคุมคู่จะต้องตั้งค่ากฎที่แสดงด้านล่างสําหรับ:
- ที่อยู่ IP ของพอร์ตการจัดการทางกายภาพ (Eth0) บนคอนโทรลเลอร์ทั้งสอง
- ที่อยู่ IP ของการจัดการที่ใช้ร่วมกันที่กําหนดให้กับที่เก็บข้อมูล
- โฮสต์ที่ใช้โปรแกรมประยุกต์ตัวเก็บรวบรวมข้อมูลของคุณ
|
ชื่อโฮสต์ |
ที่อยู่ IP สาธารณะ |
พอร์ต TCP |
|
web1.compellent.com |
76.164.8.136 |
443 |
|
Web2.compellent.com |
76.164.8.160 & 76.164.8.161 |
443 |
|
stor.g2.ph.dell.com |
143.166.135.120 (ประถมศึกษา) |
443 |
|
stor.g2.ph.dell.com |
143.166.147.96 (มัธยมศึกษา) |
443 |
|
stor.g3.ph.dell.com |
143.166.135.19 (ประถมศึกษา) |
443 |
|
stor.g3.ph.dell.com |
143.166.147.73 (มัธยมศึกษา) |
443 |
คอนโซลความปลอดภัย:
|
ชื่อโฮสต์ |
ที่อยู่ IP สาธารณะ |
พอร์ต TCP |
|
es-mc-ssh-ds1.compellent.com |
76.164.8.173 |
8443 |
|
es-mc-ssh-ssh1.compellent.com |
76.164.8.174 |
22 |
|
es-mc-ssh-ssh2.compellent.com |
76.164.8.175 |
22 |
|
Sshdisp.g3.ph.dell.com |
76.164.8.173 |
8443 & 10001 - 10008 |
ฉันจะทําการทดสอบการล้มเหลวได้อย่างไร
จําเป็นต้องทําการทดสอบการล้มเหลวก่อนการอัปเดต SCOS เพื่อยืนยันและตรวจสอบว่าการกําหนดค่า "แนวทางปฏิบัติที่ดีที่สุด" สําหรับโฮสต์นั้นถูกต้องและตรวจสอบให้แน่ใจว่าในระหว่างการอัปเดตโฮสต์จะยังคงเชื่อมต่อกับไดรฟ์ข้อมูลการจัดเก็บและหลีกเลี่ยงการสูญเสียการผลิต
เพื่อทําการทดสอบให้เสร็จสมบูรณ์โปรดทําตามขั้นตอนด้านล่าง:
1. ตรวจสอบให้แน่ใจว่าการทดสอบ Failover นี้ทําในระหว่างหน้าต่างการบํารุงรักษาที่วางแผนไว้
2. วางระบบในโหมดการบํารุงรักษา (ซึ่งจะหลีกเลี่ยงการสร้างเหตุการณ์การสนับสนุนที่ไม่จําเป็นเมื่อตัวควบคุมรีบูต)
- ในส่วนติดต่อ Dell Storage Manager (DSM) ให้คลิกขวาบนระบบที่คุณต้องการใส่ในโหมดการบํารุงรักษา
- คลิกที่ตัวเลือกต่อไปนี้แก้ไขการตั้งค่า>โหมดการทํางานทั่วไป>>การบํารุงรักษา (รูปที่ 1 ด้านล่าง (ภาษาอังกฤษเท่านั้น))
รูปที่ 1: เปลี่ยนโหมดการทํางานเป็นโหมดการบํารุงรักษา
3. ทํารีบูตตามลําดับของตัวควบคุม (ทีละตัว)
- ในส่วนติดต่อการจัดการ ให้คลิกขวาบนระบบที่คุณต้องการใส่ในโหมดการบํารุงรักษา
- คลิกที่ตัวเลือกต่อไปนี้ การดําเนินการ > ระบบ >การปิดระบบ/เริ่มการทํางานใหม่
- ในหน้าต่างเมนูใหม่ ให้เลือก เริ่มต้นใหม่และเริ่มต้นใหม่ตามลําดับ (สําหรับตัวเลือกการเริ่มระบบของคอมพิวเตอร์ใหม่) (รูปที่ 2 ด้านล่าง (เป็นภาษาอังกฤษเท่านั้น))
รูปที่ 2: ตัวเลือกการรีสตาร์ทเพื่อเริ่มต้นใหม่ตามลําดับ
4. ในระหว่างการทดสอบ Failover คุณควรตรวจสอบโฮสต์และตรวจสอบให้แน่ใจว่าพวกเขาสามารถเข้าถึงไดรฟ์ข้อมูลได้
- เชื่อมต่อกับโฮสต์และตรวจสอบว่าไดรฟ์ข้อมูลออนไลน์อยู่และเข้าถึงข้อมูลได้
- ใน DSM สถานะการเชื่อมต่อควรเป็นบางส่วน ถ้าสถานะการเชื่อมต่อหยุดทํางาน (รูปที่ 3 ด้านล่าง (เป็นภาษาอังกฤษเท่านั้น))
รูปที่ 3: สถานะการเชื่อมต่อบน Host
5 เมื่อทดสอบเสร็จแล้วตรวจสอบให้แน่ใจว่าระบบถูกนํากลับเข้าสู่โหมดปกติ
- ในส่วนติดต่อการจัดการ ให้คลิกขวาที่ระบบที่คุณต้องการใส่ในโหมดการบํารุงรักษา
- คลิกที่ตัวเลือกต่อไปนี้แก้ไขการตั้งค่า>โหมดการทํางาน>ทั่วไป>ปกติ (รูปที่ 1 ด้านบน (ภาษาอังกฤษเท่านั้น))
ฉันจะตรวจสอบแนวทางปฏิบัติที่ดีที่สุดได้ที่ไหน
เอกสารแนวทางปฏิบัติที่ดีที่สุดมีให้ที่เอกสารทางเทคนิคของ SC Series ขอแนะนําให้ตรวจสอบเพื่อให้แน่ใจว่าการกําหนดค่าเหมาะสมที่สุดก่อนทําการอัปเดต
ในเอกสารทางเทคนิคของ SC Series โปรดดูเอกสารที่เกี่ยวข้องกับระบบปฏิบัติการที่ใช้ในสภาพแวดล้อมของคุณ ใส่ใจกับการตั้งค่า MPIO, HBA และการหมดเวลาเพื่อให้แน่ใจว่าการตั้งค่าการเริ่มระบบจาก SAN, ไดรฟ์ข้อมูลสด และการจําลองแบบถูกตั้งค่าตามที่อธิบายไว้ในเอกสารแนวทางปฏิบัติที่ดีที่สุดข้างต้น
ในหน้าเดียวกันให้ตรวจสอบเมทริกซ์ความเข้ากันได้เพื่อตรวจสอบความเข้ากันได้ของไดรเวอร์ / เฟิร์มแวร์ของคุณ
การอัปเดตใช้เวลานานแค่ไหน?
การใช้การปรับปรุงบริการใน‐อาจใช้เวลามากกว่าการใช้การปรับปรุงระหว่างการขัดข้องของบริการตามกําหนดการ
กระบวนการอัปเดต SCOS อาจใช้เวลา:
- ประมาณ 10-20 นาทีสําหรับการดาวน์โหลดแพ็คเกจอัปเดต SCOS (ขึ้นอยู่กับความเร็วของการเชื่อมต่ออินเทอร์เน็ตของคุณ)
- ประมาณ 20-40 นาทีสําหรับการทดสอบการล้มเหลว (ขึ้นอยู่กับขนาดสภาพแวดล้อมและการกําหนดค่า)
- ประมาณ 1 ชั่วโมงต่อตัวควบคุม SC10, SC20, SC30, SC40
- ประมาณ 2 ชั่วโมงต่อรุ่น SC40x0 และคอนโทรลเลอร์ที่สูงขึ้น
- และในขั้นตอนแยกต่างหากเวลาเพิ่มเติมสําหรับการอัปเดตเฟิร์มแวร์ในส่วนประกอบที่เก็บข้อมูลอื่น ๆ :
- ประมาณ 10-20 นาทีต่อตู้
- ประมาณ 1 นาทีต่อดิสก์
ข้อควรพิจารณาสําหรับการจําลองแบบ/วอลุ่มสด
- การจําลองแบบควรถูกหยุดชั่วคราวตลอดระยะเวลาของการปรับปรุงเพื่อให้แน่ใจว่าการจําลองแบบเหล่านั้นจะยังคงถูกทําข้อมูลให้ตรงกัน
- ถ้าใช้ไดรฟ์ข้อมูลสดที่เปิดใช้งานการล้มเหลวอัตโนมัติ
- ตัวเก็บรวบรวมข้อมูลหลักที่ใช้บริการ Tiebreaker ที่ใช้โดย LV AFO จะอยู่ที่ไซต์ที่ 3 แทนที่จะเป็นไซต์ต้นทางหรือไซต์ปลายทาง หากตั้งอยู่บนไซต์หลัก / รอง tiebreaker อาจไม่สามารถสื่อสารกับไซต์ตรงข้ามในระหว่างการล้มเหลวและอาจทําให้ระบบคิดว่ามันถูกแยกออก ในสถานการณ์สมมตินี้ การกระทําเริ่มต้นที่ดําเนินการโดยบนระบบคือการใช้ปริมาณสดแบบออฟไลน์
- ถ้าโฮสต์ที่เรียกใช้บริการตัวเก็บรวบรวมข้อมูลหลักและ Tiebreaker มีการ์ดเครือข่ายหลายตัว
- ทดสอบว่าบทบาทการแลกเปลี่ยนปริมาณสดทํางานก่อนที่จะดําเนินการทดสอบการล้มเหลวหรือการอัปเดต SCOS
- ตรวจสอบให้แน่ใจว่าปริมาณสดในระบบ Compellent ที่กําลังอัปเดตจะแสดงเป็นปริมาณสดรองก่อนที่จะดําเนินการอัปเดต
- ตรวจสอบให้แน่ใจว่าได้ทําการปรับปรุงระหว่างหน้าต่างการบํารุงรักษาตามกําหนดการ
จะเกิดอะไรขึ้นถ้าฉันมีปัญหาในการปรับปรุง
การอัปเดตศูนย์จัดเก็บข้อมูล ในกรณีที่ไม่น่าจะเกิดขึ้นโปรดโทรหาฝ่ายสนับสนุนของ Dell EMC ในกรณีเหล่านี้ Dell EMC Support อาจต้องเข้าถึงระบบโดยใช้สายเคเบิลอนุกรมที่ให้มา ด้วยเหตุนี้เราขอแนะนําให้มีพนักงานในสถานที่พร้อมระบบและสายเคเบิลอนุกรมทุกที่ที่เป็นไปได้ก่อนที่จะพยายามอัปเดต