NetWorker : La licence du serveur s’affiche en mode D’évaluation
Summary: Le serveur NetWorker a été configuré avec une licence valide, mais affiche désormais sa conformité de licence « Eval », indiquant qu’elle est en mode d’évaluation.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Dans les Propriétés du serveur sous l’onglet Configuration, sous le rapport de conformité de la conformité de la licence, la conformité complète indique Eval :
Figure 1 : La licence des propriétés du serveur NetWorker indique que la conformité est « Eval ».
L’en-tête de l’interface utilisateur NMC affiche également « eval » :
Figure 2 : L’en-tête de NetWorker Management Console (NMC) affiche « Eval ».
Figure 1 : La licence des propriétés du serveur NetWorker indique que la conformité est « Eval ».
L’en-tête de l’interface utilisateur NMC affiche également « eval » :
Figure 2 : L’en-tête de NetWorker Management Console (NMC) affiche « Eval ».
Cause
Ce problème peut avoir différentes causes, par exemple :
- Ce problème peut être dû à l’exécution d’une reprise après sinistre du serveur NetWorker (NSRDR).
- Le système d’exploitation du serveur NetWorker a été mis à niveau.
- Corruption de la base de données des ressources du serveur NetWorker.
Resolution
Utilisez nsradmin pour supprimer la licence lorsque les services sont arrêtés et qu’après le redémarrage des services, la licence a été re-lue.
Suivez les étapes ci-dessous pour supprimer la licence hors ligne de la base de données :
1. Copiez la licence à partir du texte de la licence CLP dans le bloc-notes.
2. Arrêtez les services NetWorker et les services NMC (gstd).
3. Vérifiez que tous les processus obsolètes sont en cours d’exécution, si oui, supprimez le processus.
Suivez les étapes ci-dessous pour supprimer la licence hors ligne de la base de données :
1. Copiez la licence à partir du texte de la licence CLP dans le bloc-notes.
2. Arrêtez les services NetWorker et les services NMC (gstd).
Sous Windows :
net stop nsrexecd
Sous Linux :
systemctl stop networker
systemctl stop gst
3. Vérifiez que tous les processus obsolètes sont en cours d’exécution, si oui, supprimez le processus.
Sous Windows :
pour vérifier les processus obsolètes :
pour vérifier les processus obsolètes :
tasklist | findstr nsr
Pour arrêter le processus obsolète :
tskill <pid>
Sous Linux :
Pour vérifier les processus obsolètes :
ps -ef | grep nsr
Pour arrêter le processus obsolète :
kill -9 <pid>
4. Copiez le res sous /nsr dans n’importe quel emplacement sûr.
5. Accédez à nsrdb à l’aide de nsradmin en mode hors ligne :
Windows :
nsradmin -d "C:\Program Files\EMC NetWorker\nsr\res\nsrdb"
Linux :
nsradmin -d /nsr/res/nsrdb
6. Saisissez ensuite :
nsradmin>t
Known type: NSR,..... all the types will be listed
nsradmin>p type:NSR license
nsradmin>delete type:NSR license;name:CLP Capacity License
Delete? y
deleted resource id.....
7. Redémarrez les services.
Sous Windows :
net start nsrd && net start gstd
Sous Linux :
systemctl start networker
systemctl start gst
8. Lancez ensuite NMC et vérifiez que la conformité complète est mise à jour.
Affected Products
NetWorkerArticle Properties
Article Number: 000213006
Article Type: Solution
Last Modified: 31 Oct 2023
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.