NVP vProxy: VM-sikkerhedskopier fra stand-alone ESXi mislykkes med "Modtaget en HTTP-kode: 400...."
Summary: NetWorker VMware Protection (NVP) vProxy-enheden implementeres på en separat VMware ESXi-hypervisorvært (7.0U3). Alle VM-sikkerhedskopieringer mislykkes øjeblikkeligt med meddelelsen "Kunne ikke oprette BackupVmSession-ressource. Der opstod en fejl under logføring til CIS-vært, ikke hentning af guestOSImage-oplysninger" ...
Symptoms
En enkeltstående ESXi-vært blev føjet til NetWorker (ingen vCenter-server).
ESXi-værten findes i version 7.0U3.
vProxy-versionen er på 4.3.0-46.
ESXi-værten blev tilføjet ved hjælp af root-kontoen og indstillingen "implementeret i cloud" (påkrævet):
Figur 1: Skærmbillede af siden Rediger vCenter
VM-sikkerhedskopiering mislykkes øjeblikkeligt med følgende fejlmeddelelse i handlingsloggen:
Figur 2: Meddelelse om sikkerhedskopieringsfejl i handlingsloggen
Fejlmeddelelse:
07/13/2023 09:35:56 AM rhelvm8: Unable to start backup on vProxy 'vproxy02.emclab.local': Received an HTTP code: 400, libCURL message: "", vProxy message: "Error received from vProxy ="-400: Unable to initialize new resource in engine. Failed to create BackupVmSession resource. Error logging to CIS host, not fetching guestOSImage details. Failed to login to CIS service at 'HTTPS://192.xxx.xx.xxx/rest/com/vmware/cis/session'. A 'POST' method to CIS service at 'HTTPS://192.xxx.xx.xxx/rest/com/vmware/cis/session' responded with code 400. Failed to decode error message: Failed to decode type '*cis.CisApiError' from '': unexpected end of JSON input". ", url: "https://vproxy02.emclab.local:9090/api/v1/BackupVmSessions",
Cause
vProxy-fejl i håndtering af meddelelser
Meddelelsen "Fejl ved logføring af CIS-vært henter ikke guestOSImage-oplysninger" skal håndteres som en advarsel og tillade, at sikkerhedskopieringen fortsætter. Den behandles dog som en fejl og forhindrer sikkerhedskopier i at køre.
Resolution
En midlertidig løsning er at nedgradere til vProxy 4.3.0-41.
Dette problem forventes løst i en kommende vProxy-version. Tjek https://www.dell.com/support/home/product-support/product/networker-family/drivers for tilgængelighed.