NVP vProxy: VM-säkerhetskopieringar från fristående ESXi misslyckas med "Fick en HTTP-kod: 400...."
Summary: NetWorker VMware Protection (NVP) vProxy-enheten distribueras på en fristående VMware ESXi-hypervisorvärd (7.0U3). Alla säkerhetskopieringar av virtuella datorer misslyckas omedelbart med meddelandet "Det gick inte att skapa BackupVmSession-resursen. Fel vid loggning till CIS-värden, hämtar inte guestOSImage-information" ...
Symptoms
En fristående ESXi-värd har lagts till i NetWorker (ingen vCenter-server).
ESXi-värden har version 7.0U3.
vProxy-versionen är 4.3.0-46.
ESXi-värden lades till med hjälp av rotkontot och alternativet "deployed in cloud" (obligatoriskt):
Bild 1: Skärmbild av sidan Ändra vCenter
Säkerhetskopieringen av den virtuella datorn misslyckas omedelbart med följande felmeddelande i åtgärdsloggen:
Bild 2: Meddelande om fel vid säkerhetskopiering av åtgärd i åtgärdsloggen
Felmeddelande:
07/13/2023 09:35:56 AM rhelvm8: Unable to start backup on vProxy 'vproxy02.emclab.local': Received an HTTP code: 400, libCURL message: "", vProxy message: "Error received from vProxy ="-400: Unable to initialize new resource in engine. Failed to create BackupVmSession resource. Error logging to CIS host, not fetching guestOSImage details. Failed to login to CIS service at 'HTTPS://192.xxx.xx.xxx/rest/com/vmware/cis/session'. A 'POST' method to CIS service at 'HTTPS://192.xxx.xx.xxx/rest/com/vmware/cis/session' responded with code 400. Failed to decode error message: Failed to decode type '*cis.CisApiError' from '': unexpected end of JSON input". ", url: "https://vproxy02.emclab.local:9090/api/v1/BackupVmSessions",
Cause
vProxy-fel i meddelandehantering
Meddelandet "Fel vid loggning till CIS-värden hämtar inte guestOSImage details" ska hanteras som en varning och tillåta att säkerhetskopieringar fortsätter, men det behandlas som ett fel och hindrar säkerhetskopieringar från att köras.
Resolution
En tillfällig lösning är att nedgradera till vProxy 4.3.0-41.
Det här problemet förväntas åtgärdas i en kommande vProxy-version. Kontrollera https://www.dell.com/support/home/product-support/product/networker-family/drivers tillgänglighet.