NVP-vProxy: VM-Backups vom eigenständigen ESXi schlagen mit folgender Meldung fehl: "Received an HTTP code: 400...."
Summary: Die NVP-vProxy-Appliance (NetWorker VMware Protection) wird auf einem eigenständigen VMware ESXi-Hypervisor-Host (7.0U3) bereitgestellt. Alle VM-Backups schlagen sofort mit der Meldung "Fehler beim Erstellen der BackupVmSession-Ressource. Fehlerprotokollierung auf CIS-Host, es werden keine guestOSImage-Details abgerufen." ...
Symptoms
Ein eigenständiger ESXi-Host wurde NetWorker hinzugefügt (kein vCenter Server).
Der ESXi-Host hat Version 7.0U3.
vProxy-Version ist 4.3.0-46.
Der ESXi-Host wurde mit dem Root-Konto und der Option "Deployed in Cloud" (erforderlich) hinzugefügt:
Abbildung 1: Screenshot der Seite "Modify vCenter"
Die VM-Backupaktion schlägt sofort mit der folgenden Fehlermeldung im Aktionsprotokoll fehl:
Abbildung 2: Meldung zum Fehlschlagen der Backupaktion im Aktionsprotokoll
Fehlermeldung:
07/13/2023 09:35:56 AM rhelvm8: Unable to start backup on vProxy 'vproxy02.emclab.local': Received an HTTP code: 400, libCURL message: "", vProxy message: "Error received from vProxy ="-400: Unable to initialize new resource in engine. Failed to create BackupVmSession resource. Error logging to CIS host, not fetching guestOSImage details. Failed to login to CIS service at 'HTTPS://192.xxx.xx.xxx/rest/com/vmware/cis/session'. A 'POST' method to CIS service at 'HTTPS://192.xxx.xx.xxx/rest/com/vmware/cis/session' responded with code 400. Failed to decode error message: Failed to decode type '*cis.CisApiError' from '': unexpected end of JSON input". ", url: "https://vproxy02.emclab.local:9090/api/v1/BackupVmSessions",
Cause
vProxy-Fehler bei der Meldungsverarbeitung
Die Meldung "Fehlerprotokollierung auf CIS-Host ruft keine guestOSImage-Details ab" sollte als Warnung behandelt werden und die Fortsetzung von Backups ermöglichen. Dies wird jedoch als Fehler behandelt und verhindert, dass Backups ausgeführt werden.
Resolution
Ein vorübergehender Workaround ist ein Downgrade auf vProxy 4.3.0-41.
Dieses Problem wird voraussichtlich in einer kommenden vProxy-Version behoben. Überprüfen Sie https://www.dell.com/support/home/product-support/product/networker-family/drivers auf Verfügbarkeit.