PowerProtect: Data Manager report browser unable to send email report using SMTP server that has StartTLS enabled.

Summary: Emails reports are not received by the users.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After adding email setup configuration to PowerProtect Data Manager (PPDM), reports are not received via email messages.

On reporting server, an error similar to the following is present in the server.log file:
2024-02-05 15:32:37,010 ERROR [com.emc.dpa.command.notification.NotificationSenderMDB] (Thread-131073) Problems while sending e-mail notification: com.sun.mail.smtp.SMTPSendFailedException: 451 5.7.3 STARTTLS is required to send mail [MailServer 2024-02-05T08:32:36.994Z 08DC257F199B3AC5]
 

Cause

The email server defined in the configuration has StartTLS enabled. It requires clients to use StartTLS while connecting to send email messages.

Resolution

To resolve this issue, StartTLS must be enabled within configuration stored on the reporting server.

Below mentioned steps can be followed to resolve the issue.

Steps for PowerProtect Data Manager 19.16

  1. Log in to the reporting server with an admin account and then change to root. In case credentials are needed, contact DELL Technologies technical support team to help with the credentials.
  2. Change the directory to '/opt/emc/dpa/services/bin' folder. 
# cd /opt/emc/dpa/services/bin
 
  1. Run the following command to get details of the current configuration:
# ./dpa.sh ds query "select * from apollo.mail_server_configuration"

  
  1. Note down value reported under f_id and f_start_tls_enabled. The following is an example of the expected outcome:
# ./dpa.sh ds query "select * from apollo.mail_server_configuration"
EMC Data Protection Advisor
                 f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------
 d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f
(1 row)
 
  1. If the f_start_tls_enabled value is set to "f", it must be changed to "t". To make this change, following command can be used:
./dpa.sh ds query "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'"

  
Example:
# ./dpa.sh ds query "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"

EMC Data Protection Advisor

UPDATE 1
 
  1. Restart services on the reporting server using command below:
# ./dpa.sh svc restart 
 

Steps for PowerProtect Data Manager 19.17

  1. Log in to the reporting server with an admin account and then change to root. In case credentials are needed, contact DELL Technologies technical support team to help with the credentials.

    Note: At a few different steps the password is mentioned as 'Password123!'. That must be updated with a real password.
     
  2. Run the following command to get details of the current configuration:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "select * from apollo.mail_server_configuration" 
 
  1. Note down value reported under f_id and f_start_tls_enabled. The following is an example of the expected outcome:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "select * from apollo.mail_server_configuration"    
EMC Data Protection Advisor                     
f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled    
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------     
d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f    
(1 row)   

  

 

  1. If the f_start_tls_enabled value is set to "f", it must be changed to "t". To make this change the following command can be used:
#psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "UPDATE apollo.mail_server_configuration SET f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'" 
 
Example:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/apollo -c "UPDATE apollo.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"  
 
EMC Data Protection Advisor  
 
UPDATE 1 
 
  1. Restart services on the reporting server using command below:
# systemctl start reporting-service.service reporting-data-collector.service  reporting-data-processor.service reporting-generator.service 

 

Steps for PowerProtect Data Manager 19.18

  1. Log in to the reporting server with an admin account and then change to root. In case credentials are needed, contact DELL Technologies technical support team to help with the credentials.

    Note: At few different steps the password is mentioned as 'Password123!'. That must be updated with a real password.
     
  2. Run the following command to get details of the current configuration:
 
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "select * from reportconfig.mail_server_configuration" 
 
  1. Note down value reported under f_id and f_start_tls_enabled. The following is an example of the expected outcome:
EMC Data Protection Advisor
                     f_id                 |     f_lastmodified      |           f_credential_id            |  f_from_address   |     f_hostname     | f_port | f_security_protocol | f_start_tls_enabled    
--------------------------------------+-------------------------+--------------------------------------+-------------------+--------------------+--------+---------------------+---------------------     
d61193eb-be0c-42aa-a841-7ef1b281d008 | 2023-12-12 09:02:01.978 | c7321673-3879-4c5e-b0f2-a0029f8815c9 | ppdm@yourcompany.com | smtp.emailserverdomain.com |    587 | None                | f    
(1 row)    
 
  1. If the f_start_tls_enabled value is set to "f", it must be changed to "t". To make this change the following command can be used:
psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "UPDATE reportconfig.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'f_id identified from step above'"   
 
Example:
# psql postgresql://reportinguser:'Password123!'@127.0.0.1:9003/reporting -c "UPDATE reportconfig.mail_server_configuration SET  f_start_tls_enabled = 't' WHERE f_id = 'd61193eb-be0c-42aa-a841-7ef1b281d008'"  

EMC Data Protection Advisor  
 
UPDATE 1 
 
  1. Restart services on the reporting server using command below:
# systemctl start reporting-service.service reporting-data-collector.service  reporting-data-processor.service reporting-generator.service 

Affected Products

PowerProtect Data Manager, PowerProtect Data Manager Essentials
Article Properties
Article Number: 000221887
Article Type: Solution
Last Modified: 26 May 2025
Version:  3
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