USB Drives Connected to Dell Dock Cause USB Issues on Dell Laptops
Summary: This article provides information about Latitude and Inspiron laptops connected to a Dell dock with a SanDisk or Transcend USB drive attached causing USB connectivity issues.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Affected Platforms:
- Latitude 7455
- Inspiron 14 Plus 7441
Affected Products:
- Dell Dual Charge Dock HD22Q
- Dell Dock - WD19S
Note: These issues occur when an external monitor and a SanDisk or Transcend USB Type-C USB drive are connected to the dock, along with other USB devices.
When the issue occurs, is an Unknown USB device(Port reset failed) in Device Manager with a Yellow bang displayed on it.
Cause
When the communication cannot be completed:
- The dock sends a hard reset to the host.
- And a warm reset to the SanDisk or Transcend USB type-C thumb drive.
However, the SanDisk or Transcend USB type-C thumb drive does not respond to the warm reset, which causes this issue.
Note: Other USB type C vendors were within the USB spec and completed the warm reset correctly.
Resolution
Dell engineering is aware of this issue and has released a firmware update, download the Dell Dock Firmware Package v01.00.23 or later from the product page of your Dell dock.
Affected Products
Dell Dual Charge Dock HD22Q, Dell Dock – WD19S, Inspiron 14 Plus 7441, Latitude 7455Article Properties
Article Number: 000226467
Article Type: Solution
Last Modified: 24 Apr 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.