PowerStore: System Health Check fails for "Unable to perform health check due to communication error"

Summary: After installing the PowerStore-health_check-4.0.1.0-2416779-retail.tgz.bin package, the system health check fails multiple steps with error "Unable to perform health check due to communication error." Control Path (CP) may also be impacted due to CPU0 high load. ...

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Symptoms

After installing the PowerStore-health_check-4.0.1.0-2416779-retail.tgz.bin package, the system health check fails multiple checks with error "Unable to perform health check due to communication error."

 

screen shot of SHC communication errors

 

UI details may also show that the System Health Check Fireman command failed (0xE0F010200004)

 

screen shot of SHC fireman error

 

Due to CPU0 high load, Control Path (CP) and other management functions may also be impacted. 

 

Cause

The service cyc.bsc_status_check_service.service is not restarted during the installation of the PowerStore-health_check-4.0.1.0-2416779-retail.tgz.bin package. This results in CPU0 high load which causes system health check to fail multiple checks with error "Unable to perform health check due to communication error" due to exceeding timeout values.

Resolution

Workaround:

Rebooting each node one at a time using the svc_node reboot command will work around the issue and allow the system health check to pass. It is recommended to reboot the peer (non-primary) node first and the primary node second. It is important to verify the first node is fully up and functional before rebooting the second node. The svc_diag list --basic command can be used to identify which node is the primary.
 

===================== Nodes ======================

id: N1

name: WK-A1234-appliance-1-node-A

slot: 0

appliance_id: A1
is_primary: False
 
 
id: N2

name: WK-A1234-appliance-1-node-B

slot: 1

appliance_id: A1
is_primary: True

 

Dell Technical Support can issue a root level command to restart the service cyc.bsc_status_check_service.service if rebooting the nodes one at a time is not a viable workaround. Escalate to Dell Technical Support and reference this knowledge article for assistance.

 

Fix:

This issue is fixed in the PowerStore-health_check-4.0.1.0-2424376-retail.tgz.bin package.

Affected Products

PowerStore
Article Properties
Article Number: 000267427
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  5
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