NVP vProxy: Registration Fails "Unable to log in to vCenter..Incorrect Username or Password"

Summary: The registration of a NetWorker VMware Protection (NVP) vProxy fails. The error returned is "HTTP 500 Unable to log in to vCenter 'vcsa.amer.lan': ServerFaultCode: Cannot complete login due to an incorrect username or password."" ...

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Symptoms

The registration of a NetWorker VMware Protection (NVP) vProxy fails.
The following error is logged in the Log section of the NetWorker Management Console (NMC) Monitoring tab:

VM proxy Warning: Unable to register NSR VMware proxy 'VPROXY_NAME': Received an HTTP code: 500, libcurl message: "", vProxy message: "Error received from vProxy ="500: Unable to log in to vCenter 'VCENTER_NAME': ServerFaultCode: Cannot complete login due to an incorrect user name or password.".

The NetWorker server's rendered daemon.raw reports the same errors:

Linux: /nsr/logs/daemon.raw
Windows: C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw

Example:

71193 02/05/2025 10:50:45 AM  nsrd NSR info VM proxy Info: Initiating registration of NSR VMware proxy 'nsr-vproxy01.amer.lan'
71193 02/05/2025 10:50:50 AM  nsrd NSR info VM proxy Warning: Unable to register NSR VMware proxy 'nsr-vproxy01.amer.lan': Received an HTTP code: 500, vProxy ="500: Unable to log in to vCenter 'vcsa.amer.lan': ServerFaultCode: Cannot complete login due to an incorrect user name or password.".

The NMC VMware View refresh is working. This validates that the NetWorker server has the correct vCenter credentials.
 

NOTE: If the VMware View refresh fails to load the vCenter inventory. Ensure that the vCenter credentials are correct. See the Additional Info section for troubleshooting instructions.

Cause

The vProxy is not resolving the vCenter server correctly.

Example scenario.

The vProxy appliance has an incorrect IP address in its /etc/hosts file. The vProxy can ping this IP address. The IP address is for another VMware vCenter, so connections to port 443 also succeed; however, it is not the correct vCenter so authentication fails:
nsr-vproxy01:~ # ping -c 4 vcsa.amer.lan
PING vcsa.amer.lan (192.168.9.114) 56(84) bytes of data.
64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=1 ttl=64 time=0.455 ms
64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=2 ttl=64 time=0.399 ms
64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=3 ttl=64 time=0.698 ms
64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=4 ttl=64 time=0.361 ms

--- vcsa.amer.lan ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3049ms
rtt min/avg/max/mdev = 0.361/0.478/0.698/0.131 ms
nsr-vproxy01:~ #
nsr-vproxy01:~ # curl -v vcsa.amer.lan:443
*   Trying 192.168.9.114:443...
* Connected to vcsa.amer.lan (192.168.9.114) port 443 (#0)
> GET / HTTP/1.1
> Host: vcsa.amer.lan:443
> User-Agent: curl/8.0.1
> Accept: */*
>
* Empty reply from server
* Closing connection 0
curl: (52) Empty reply from server
We can see from the NetWorker server that the vCenter resolves to a different IP address:
[root@nsr ~]# nslookup vcsa.amer.lan
Server:         192.168.9.100
Address:        192.168.9.100#53

Name:   vcsa.amer.lan
Address: 192.168.9.111
NOTE: This scenario is an example, the root cause of the issue is that the vProxy is resolving the vCenter to an incorrect IP address. Other symptoms may be observed depending on the site and scenario.

Resolution

This is a name resolution issue.

NetWorker: Name Resolution Troubleshooting Best Practices
 

  • If the vCenter IP address is set in the vProxy's /etc/hosts file, ensure that it is the correct IP address for the vCenter. Also, ensure that the /etc/hosts file does not contain multiple entries for the vCenter hostname or IP address.
  • If the vCenter IP address is not set in the vProxy's /etc/hosts file, ensure that it is resolving to the correct DNS server. The DNS server addresses are defined in the vProxy's /etc/resolv.conf. 
IP_ADDRESS          VCENTER_FQDN         VCENTER_SHORTNAME_ALIAS


Once the vProxy is resolving to the correct vCenter IP address, the registration process succeeds:

Successful vProxy Registration

Additional Information

If the NMC VMware View refresh fails, there might be an issue resolving or authenticating with the vCenter from the NetWorker server.

1. Ensure that the NetWorker server is resolving the vCenter hostname to the correct IP address. Check the NetWorker server's hosts file for any conflicting IP addresses for the vCenter server.

Linux: /etc/hosts
Windows: C:\Windows\System32\drivers\etc\hosts
2. Validate that you can log in to the vCenters vSphere web interface using the same credentials used to add the vCenter to NetWorker.
A. From NMC Protection->VMware View, right-click the vCenter and select Modify vCenter.
vCenter Credentials
B. If you can log in to vSphere with the same account, update the password in NetWorker to ensure it is correct.
C. If you cannot log in to vSphere, consult your VMware Administrator to check if the account is correct, not locked, and the password is accurate.
3. Once VMware View refreshes successfully, monitor the vProxy registration to see if it completes.

The ProxyHC utility can also be used to validate vCenter connectivity and permissions, see: NVP-vProxy: How to use health check tool ProxyHC on vProxy appliance

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000281396
Article Type: Solution
Last Modified: 05 Feb 2025
Version:  2
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