Only One Headset is Recognized When Two are Connected

Summary: This article provides information about when there are two headsets connected to the computer but only one is detected in Dell Display and Peripheral Manager 2.0 (DDPM).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Display and Peripheral Manager 2.0
  • Dell Pro Premium Wireless ANC Headset WL7024
  • Dell Pro Plus Wireless ANC Headset WL5024
  • Dell Pro Wireless Headset WL3024

This issue occurs under the following conditions:

  1. Installing DDPM software on a computer
  2. Connecting a headset using a dongle
  3. Connecting a second headset using a second dongle
  4. DDPM only shows one headset connected

Cause

The same behavior is exhibited in DPeM: It is unable to identify two headsets simultaneously.

Resolution

Disconnect one dongle, only use one headset at a time.

Affected Products

Dell Display and Peripheral Manager, Dell Pro Wireless Headset WL3024, Dell Pro Plus Wireless ANC Headset WL5024, Dell Pro Premium Wireless ANC Headset WL7024
Article Properties
Article Number: 000286286
Article Type: Solution
Last Modified: 22 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.