Dell Unity: DNS settings lost during NDU

Summary: After performing a code upgrade on a Unity VSA or Physical box, the management DNS is removed.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

4.0.1.8404134 SP1.2 has been released which resolve the issue.

After code upgrade, the statically configured DNS settings were removed for the management network, the contents of the file /etc/resolv.conf become erased. User does not receive an email about successful completion of the upgrade. All services that require DNS name resolution (NTP, SMTP, and so on) do not work properly until DNS settings are reentered by hand. Other than that, the user cannot connect to Unisphere UI or UEM CLI using the system domain name.

Note: This issue does not affect the NAS server DNS settings.

 

Cause

This is currently impacting upgrades involving the below code revisions.

  • 4.0.1.8194551 SP1

Code upgrade to product 4.0.1.8194551 erases DNS settings, if the latter were entered manually (Settings -> Management -> DNS Servers: Manage Domain Name Servers -> Configure DNS server address manually). After upgrade, the contents of file /etc/resolv.conf are not restored. It stops the DNS name resolving and deletes the domain name information from the system. In turn, it may affect networking services, including NTP and SMTP, and remove the system domain name from the management connection SSL certificate.

Due to a persistence of settings issue that may occur post upgrade to Unity Operating Environment (OE) 4.0.1.8194551, Dell Technologies decided to remove this Unity and UnityVSA release from support.emc.com.
A revised OE release is available 4.0.1.8404134 Unity SP1.2.

Customers who were planning to upgrade to 4.0.1.8194551 are suggested to wait to upgrade to the upcoming release.
For customers already running 4.0.1.8194551, review that your DNS server preferences are set correctly under Unisphere > Settings > Management > DNS Server, and update as required.

Contact Dell Technologies support if you have any questions - go to Dell Technologies Online Support at: https://www.dell.com/support/home. After logging in, locate Create a service request.

 

Resolution

The current workaround is to recreate the DNS settings in the management setup.

UI:

  1. Browse to the Settings Menu in the upper right
  2. Click the Management section then DNS Server
  3. For manually configured DNS, click Add and readd the original DNS servers.
  4. Click "Apply" button at the bottom of the dialog.
  5. Browse to: System --> Service -->Service Tasks
  6. Select "Restart Management Software," then press "Execute"
  7. Refresh the browser window. You may have to wait for a few minutes to allow management software to start.
  8. If asked, confirm the security exception for this connection.
Manage Domain Name Servers

UEMCLI:

  1. Connect to the system by IP address.
  2. For each DNS address, enter the following command:
    uemcli /net/dns/config set -nameServer <value>
  3. Then restart the management software by the command shown below.
    Note: It should be performed from the service administrator account:
    uemcli  u service  p <service password> /service/system restart
  4. If the security certificate is changed, accept the new certificate as usual.

After the last step, you could connect to the system by name again.

Upgrade:

The latest release of SP1 contains the fix for this issue 4.0.1.84.04134.

 

Affected Products

Dell EMC Unity Family

Products

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family , Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition ...
Article Properties
Article Number: 000052102
Article Type: Solution
Last Modified: 19 Nov 2025
Version:  4
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