Resolving an NVIDIA Installer Failure after an Operating System Upgrade
Summary: The following article provides information about four methods to resolve an issue seen with the NVIDIA installer failing after upgrading Windows 10.
Symptoms
The NVIDIA installer gives an error on every install attempt after upgrading Windows 10
There are several reports about the NVIDIA installer failing after upgrading to the latest version of the Windows 10 operating system. This guide helps in resolving this issue on your Dell computer.
Cause
Engineering identifies this as a software issue. Rule out the graphics driver, take the antivirus out of the equation, and kill any NVIDIA processes that are running.
Resolution
Work through each of the following methods in order until your issue is resolved.
- Back up all personal data. For more information, see: Back Up and Recovery
- Connect the AC adapter if updates are being run on a laptop.
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Update the NVIDIA driver:
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Updating the driver to the latest version on the computer resolves the issue. To download and install the driver, see: How to Download and Install Dell Drivers and Firmware
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Some antivirus applications may cause the NVIDIA installer to fail. Temporarily closing the antivirus while running a specific installer may resolve this issue:
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On Dell platforms, the antivirus displays an icon in the system taskbar in a Windows operating system.
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Right clicking that icon opens up further options depending on the antivirus manufacturer:
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Open the antivirus application or agent to turn it off
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Turn off the active scanner
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Turn off the antivirus until the next restart
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Once the install is complete, ensure that the antivirus is turned back on. Do not leave your device unprotected.
Redundant NVIDIA files and processes can lead to an installation failure:
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Open the task manager by right clicking an empty part of the taskbar or by holding down the CTRL, Shift, and Esc keys together and select Task Manager from the menu that appears:
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Click the processes tab.
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Select every process related to NVIDIA.
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Right click each and select End Task to close the process.
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Go to the boot drive folder and remove the following files:
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C:\windows\system32\DRiverStore\FileRepository\nvdsp.inf file -
C:\windows\system32\DRiverStore\FileRepository\nv_lh file -
C:\windows\system32\DRiverStore\FileRepository\nvoclock file -
C:\Program Files\NVIDIA Corporation\ -
C:\Program Files(x86)\NVIDIA Corporation\
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Restart your device.
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Try rerunning the NVIDIA installer in a custom install.
Follow these steps to run a clean installation from the NVIDIA installer:
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Have the system sit idle for 20 minutes to ensure that Windows has finished any updates for the upgraded operating system.
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As in Method I, download the latest version of the driver to your computer.
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Run the driver unpack/install with administrator privileges by right clicking the downloaded file and selecting Run as Administrator.
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Follow the on-screen instructions to the install options screen.
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Select Custom and place a checkmark next to Perform a Clean Installation.
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Once the installation is complete, restart the computer.
If this does not resolve your issue contact Technical Support:
- Dell Support Site: Contact Us