IDPA Reporting and Analytics Server is Not Sending Reports Using email
Summary: This article covers the failure of Integrated Data Protection Appliance Reporting and Analytics server to send out reports using email.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Scheduled reports that are set to be published using email are not being sent out.
The Report Jobs > Active Jobs shows that the reports were run. The reports have data in them.
The following errors are seen in the server.log after putting the reporting engine and publisher into debug:
The Report Jobs > Active Jobs shows that the reports were run. The reports have data in them.
The following errors are seen in the server.log after putting the reporting engine and publisher into debug:
2021-10-08 08:00:00,540 ERROR [com.emc.dpa.command.notification.NotificationSenderMDB] (Thread-6255) Problems while sending email notification: javax.mail.MessagingException: Could not convert socket to TLS; 2021-10-08 08:00:00,540 ERROR [com.emc.dpa.command.notification.NotificationSenderMDB] (Thread-6255) Problems while sending email notification: javax.mail.MessagingException: Could not convert socket to TLS; nested exception is: javax.net.ssl.SSLException: Inbound closed before receiving peer's close_notify: possible truncation attack
Cause
SMTP server is using TLS 1.2 and DPA is using TLS 1.1. This is causing the SMTP server to close the connection due to the mismatching TLS versions.
Resolution
Run the following steps to address the issue:
- Make a copy of the
/opt/emc/dpa/services/standalone/configuration/standalone.xmlfile with the following command:
cp /opt/emc/dpa/services/standalone/configuration/standalone.xml /opt/emc/dpa/services/standalone/configuration/standalone.xml.bak
- Edit the
/opt/emc/dpa/services/standalone/configuration/standalone.xmlfile by opening it inviand making the following changes:
Add the following two lines in the
<system-properties> section:
<property name="mail.smtp.ssl.trust" value="*"/> <property name="mail.smtp.ssl.protocols" value="TLSv1.2"/>
Then save the file and exit
vi with: :x
- Restart the DPA APP service with the following command:
/opt/emc/dpa/services/bin/dpa.sh app restartContact Dell Technologies Support if you have any questions on this issue.
Affected Products
PowerProtect Data Protection SoftwareArticle Properties
Article Number: 000196204
Article Type: Solution
Last Modified: 26 Mar 2025
Version: 3
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