AppSync: Unable to run service plan because it is already in progress in another process.
Summary: Users may occasionally find a Service Plan fails to run with the error: Cannot run service plan DB47 because it is already in progress in another process.
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Symptoms
When a user runs a service plan, the following message is received:
Server log:
Cannot run service plan DB47 because it is already in progress in another process
AppSync Event output:
Application-Discovery TSK_000002 <server name> Cannot run service plan DB47 because it is already in progress in another process
02-07-2017 06:00:02.583 ERROR [ServicePlanBrokerCommandBean] Task Collision Object Found: <task> <id>6fd9f120-5b5e-4b0e-a130-8db604dce4a0</id> <lastModified>1486257365027</lastModified> <lastModifiedFormatted>Sun 02/05/2017 10:16:05 AM</lastModifiedFormatted> <collisionImmune>false</collisionImmune> <dsNames>DB47 </dsNames> <ids>68a77214-fdb2-4480-a976-57b1d928e0a6</ids> <numApps>1</numApps> <operation>mapping</operation> <phaseName>Application-Mapping</phaseName> <phaseType>mapping</phaseType> <phasepitId>c98ec955-09eb-4f3e-b7ae-9da121e4988f</phasepitId> <spId>e340e196-5dc0-4d1c-920c-a20d266b7308</spId> <spName>DB47</spName> </task> 02-07-2017 06:00:02.661 INFO [EventServiceBean] EVENT [TSK_000002]: Cannot run service plan DB47 because it is already in progress in another process(METADATA: TYPE-ERROR, TIME-2017-02-07
Cause
An AppSync job can appear to stop responding for multiple reasons both internal to the AppSync server and external.
Internal reasons may include (but are not limited to) heavy CPU load (exceed 85%) while a service plan is running or a reboot of the AppSync server during the run of a service plan.
External reasons may include (but again they are not limited to) a user script stops responding causing the AppSync Service Plan to stop responding while it waits for the script to complete. Or an AppSync client may stop responding or be slow responding resulting in an apparent stop responding of the Service Plan.
Internal reasons may include (but are not limited to) heavy CPU load (exceed 85%) while a service plan is running or a reboot of the AppSync server during the run of a service plan.
External reasons may include (but again they are not limited to) a user script stops responding causing the AppSync Service Plan to stop responding while it waits for the script to complete. Or an AppSync client may stop responding or be slow responding resulting in an apparent stop responding of the Service Plan.
Important Note: Steps should be taken to confirm the cause of the Service Plan is unavailable and resolve this before attempting the Workaround below. Reviewing the AppSync Events and Server.log may indicate where a specific Service Plan is stopped responding. For example, if a last event in a Service Plan run looks like the example below, then a user script may be stopped responding. Stopping the script on the host that is running it is likely to allow the AppSync Service plan to complete.
2021-01-22 11:17:24.655,Post-mount script,5d6fd237-81dd-4d4b-97d4-055c3280dfa7,RSC_000007,hostname,User script results: Elapsed: 00:00:00.01
Resolution
Workaround:
The below method is available to address the issue. Should you be unsure of performing this workaround or this workaround does not address the issue, contact Dell Customer Support for assistance.
The below method is available to address the issue. Should you be unsure of performing this workaround or this workaround does not address the issue, contact Dell Customer Support for assistance.
- Check the Dashboard in the AppSync UI to verify that only the stopped responding service plan is running.
- Stop AppSync server service.
- Stop AppSync Datastore service.
- Move the contents of
C:\EMC\AppSync\jboss\standalone\tmp\vfsto another folder (it can be deleted later). - Leave the folder
C:\EMC\AppSync\jboss\standalone\tmp\vfsintact but empty. - Start Datastore service.
- Start AppSync Server service.
Affected Products
AppSyncArticle Properties
Article Number: 000057134
Article Type: Solution
Last Modified: 18 Sep 2025
Version: 5
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