SourceOne Email Management: SourceOne account ca not access end users mailboxes while running activities.

Summary: SourceOne account cannot access end users mailboxes while running activities.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Use RPC/TCP protocol instead of MAPI/HTTP protocol while connecting Outlook SourceOne profile with Exchange server.

While running SourceOne email activities, SourceOne account cannot access the end users mailboxes.

Depending on the activity being selected (for example Restore, Shortcut, Archive Activities), the following errors can be observed:
 
Verbosity : ERROR
Process : P143C
Thread : T1414
Module : CoExExchProvider.cpp
Func : CoExExchProvider::LogonDS(510)
Machine : Sourceone Worker Server
Message : Cannot log on to the mailbox: (Path to Exchange Mailbox). (0x86040809) Unspecified error (0x80004005)
JobId : 59129
ActivityId : 490
ActivityType : 14


Verbosity : ERROR-LOGD
Process : P143C
Thread : T1414
Module : CExJBMBoxTasks.cpp
Func : CExJBMBoxTasks::MailboxLogon(1601)
Machine : Sourceone Worker Server
Message : Cannot log on to the provider: ExExchProvider.CoExExchProvider - Username (Path to Exchange Mailbox)(0x86040809) Unspecified error (0x80004005) [ExShortcutJBC.exe, CoExExchProvider.cpp(510).CoExExchProvider::LogonDS]
JobId : 59129

Cause

This issue is related to the connection protocol being used to establish the communication between the Outlook client and Exchange server.

The issue that is above is related to the use of connection protocol MAPI over HTTP (MAPI/HTTP) for SourceOne service account mailbox.

The SourceOne Email Management 7.2.4 only supports RPC/TCP protocol to establish the communication between Outlook client and Exchange server.

Resolution

To allow SourceOne to correctly access all user mailboxes, you must disable MAPI/HTTP. Do this you implement the following on all SourceOne servers:

The following registry entry prevents Outlook from sending the MAPI/HTTP capable flag to Exchange in the Autodiscover request. When you change the registry key on a client, it will not take effect until the next time the client performs an Autodiscover query against Exchange.

To disallow MAPI/HTTP and force RPC/HTTP to be used.
HKEY_CURRENT_USER\Software\Microsoft\Exchange]
 MapiHttpDisabled =dword:00000001

To allow MAPI/HTTP delete the MapiHttpDisabled DWORD, or set it to a value of 0 as below.
HKEY_CURRENT_USER\Software\Microsoft\Exchange]
 MapiHttpDisabled =dword:00000000

Set the registry entry that you want, close Outlook and delete the Outlook profile.
Restart Outlook and go through the profile wizard (or manually configure from control panel Mail). This should result in an immediate switch to RPC/HTTP.

Affected Products

SourceOne

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000071429
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  4
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