PowerStore: Non-Disruptive Upgrade retry failed at Pre-Upgrade Health Check.

Summary: Non-Disruptive Upgrade (NDU) retry failed at Pre-Upgrade Health Check (PUHC) due to a drive failure.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PUHC fails with the message: ssd_is_not_ready_to_start_upgrade and the PowerStore Manager does not display the drive issue.

Cause

The PowerStore Manager does not detect as an alert nor in PUHC a drive issue resulting from removing and inserting a drive into the system when the node is not in the ready state.
For example, removing and inserting the drive when one of the node was rebooting, results in the drive to remain removed on the node that was not ready, causing the conflict. This drive issue prevents NDU when the PUHC is run as part of the NDU, as PUHC fails. However, PUHC does not display a detailed reason for the failure.

Resolution

A fix for alerting such an issue that affects the drive is being planned for a future PowerStore release.

Workaround:
To find the details of the affected drive, capture the data collect and contact Technical Support for assistance.
Once the drive is identified, the impacted drive must be replaced.

Affected Products

PowerStore
Article Properties
Article Number: 000200078
Article Type: Solution
Last Modified: 21 Jul 2022
Version:  1
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