Secure Connect Gateway: Version 5.26.00.18/20 Alert delivery and device registration hotfix
Summary: Secure Connect Gateway (SCG) updated to or newly installed at 5.26.00.18 or 5.26.00.20 are having issues with products (ECS, Brocade Switches, and XtremIO) failing to send alerts (Call Homes) with file extension .cec. In addition, PowerMax v4's are experiencing an issue with new deployments or re-deployments. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
For device models ECS, Brocade Switches, and XtremIO:
The connecthomerest.log at path /var/log/esrs is showing the below errors:
Unrecognized field \"time\"

As a result of this error, the call home fails to deliver.
----------------------------------
For the device model PowerMax v4:
Powermax v4 models will not be able to perform new registrations or re-registrations while the SCG server is at 5.26.00.18 or 5.26.00.20
Cause
The cause of the failure is a change in the spring boot jackson-core and jackson-bind libraries and the upgrade of Java from version 8 to version 17 between 5.24 or earlier versions and 5.26. Prior to version 5.26, unknown attributes were ignored by default and API syntax was no case sensitive.
Resolution
To address this issue, perform the following action:
- Log in to the Secure Connect Gateway Web UI (version 5.26.00.18 or 5.26.00.20), and click About in the upper right section. Open the Hotfix Deployment screen, and apply the relevant hotfix.
This hotfix does NOT require a reboot once applied.
Note: This hotfix can be safely applied to any SCG 5.26.00.18 or 5.26.00.20 system regardless of deployed device types.
Note: ECS and XIO devices are not affected if KB000243317 was previously applied to 5.26.00.18 or if the SCG server is at 5.26.00.20 but it is still recommended to apply this new hotfix.
Affected Products
Brocade, ECS, XtremIO, PowerMax 2500, PowerMax 8500Article Properties
Article Number: 000275322
Article Type: Solution
Last Modified: 24 Jan 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.