SourceOne Email Management: Unable to open Shortcuts using offline access after recovering from a corrupt Exchange DB and restoring PST to a new mailbox.
Summary: Unable to open Shortcuts using offline access after recovering from a corrupt Exchange DB and restoring PST to a new mailbox.
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Symptoms
Users are unable to open shortcut messages after the mails were restored from a users old mailbox to his new mailbox after an Exchange Database corruption.
Following error was recorded in OfflineAccessAddIn.log on the users workstation:
Failed to access the message. Not an owner of the specified item (0x86043CEE) Error Code: 0x80070005, Folder: Foldername Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) Error Code: 0x80070005, Folder: Foldername Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) Error Code: 0x80070005, Folder: Foldername Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) Error Code: 0x80070005, Folder: Foldername Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) |CoExE6RemoteRepositoryProvider.cpp(302)|Computer
Cause
This issue is caused because the legacy DN name in Active Directory from the users old mailbox was not added to his new mailbox properties.
Resolution
You are not able to access the shortcuts after migrating the mailboxes because the user was no longer the owner of those messages , adding the users original Legacy DN to the new one, the users will now be able to access the shortcuts.
To find a users Legacy DN follow article number : 306353.
https://emcservice.my.salesforce.com/knowledge/publishing/articleOnlineDetail.apexp?id=kA5j00000008PG3
Legacy DN can be added from ADSIEDIT as well. Below are the steps for it:
To find a users Legacy DN follow article number : 306353.
https://emcservice.my.salesforce.com/knowledge/publishing/articleOnlineDetail.apexp?id=kA5j00000008PG3
Legacy DN can be added from ADSIEDIT as well. Below are the steps for it:
- Go to ADSIEDIT.MSC.
- Select the affected user >> click on properties.
- Verify the 'Legacy DN ' it would have values same as one of those obtained from SQL.
- Look for 'Proxy Address' >> click on 'add' >> type it as follows <LEGACY:/o=first organization/ou= ...etc.>
- Click apply.
- Wait for an Address synchronization to complete. This may take 24 hours.
Affected Products
SourceOne Email ManagementProducts
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000050150
Article Type: Solution
Last Modified: 26 May 2025
Version: 4
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