Dell EMC Unity: ESRS Not working due to Management IP address change. (User Correctable)
Summary: How to resolve a DELL EMC database inconsistency due to a recent Unity Array Management IP address change.
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Symptoms
Unity Management IP address changed.
After initial Unity Installation and ESRS deployment has been completed. If the Management IP address on the unity array is changed, this will leave a inconsistency on the ESRS database that can prohibit the ability for remote support to ESRS into the system. This currently requires manual intervention to update the ESRS database. This currently effects the Unity ESRS Integrated deployment.
After initial Unity Installation and ESRS deployment has been completed. If the Management IP address on the unity array is changed, this will leave a inconsistency on the ESRS database that can prohibit the ability for remote support to ESRS into the system. This currently requires manual intervention to update the ESRS database. This currently effects the Unity ESRS Integrated deployment.
Cause
ESRS deployment on the Unity platform is currently expecting a static IP address. In instances of when an array is reconfigured there is currently no mechanism to auto update the ESRS data base to accept the new IP address. So a manual update is required on the ESRS database.
Resolution
Please contact DELL EMC support, reference this KBA and supply the following KEY information.
Unity system Serial Number:
Asset Connectivity Gateway Serial Number:
Original system MGMT IP:
New system MGMT IP:
NOTE* Although the Original IP is not technically required, it will help with quicker validation the correct system is being updated.
Here is how to obtain the "Unity Serial Number" and "Asset Connectivity Gateway Serial Number".
Open a SSH session to the Unity Array & run the following command.
13:47:53 service@(none) spa:~> svc_diag |grep Serial
* System Serial Number is: APM0016150XXXX
19:07:53 service@(none) spa:~> cat /EMC/backend/CEM/eVE/etc/esrsclient.conf |grep Gate
GatewaySN=ELMESR0916XXXX
19:07:53 service@(none) spa:~>
19:07:53 service@(none) spa:~>
NOTE* If the "GatewaySN" is blank, then this is not the correct KBA to resolve the problem.
Unity system Serial Number:
Asset Connectivity Gateway Serial Number:
Original system MGMT IP:
New system MGMT IP:
NOTE* Although the Original IP is not technically required, it will help with quicker validation the correct system is being updated.
Here is how to obtain the "Unity Serial Number" and "Asset Connectivity Gateway Serial Number".
Open a SSH session to the Unity Array & run the following command.
13:47:53 service@(none) spa:~> svc_diag |grep Serial
* System Serial Number is: APM0016150XXXX
19:07:53 service@(none) spa:~> cat /EMC/backend/CEM/eVE/etc/esrsclient.conf |grep Gate
GatewaySN=ELMESR0916XXXX
19:07:53 service@(none) spa:~>
19:07:53 service@(none) spa:~>
NOTE* If the "GatewaySN" is blank, then this is not the correct KBA to resolve the problem.
Affected Products
Dell EMC Unity FamilyProducts
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity Family |Dell EMC Unity All Flash
, Dell EMC Unity Family, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
...
Article Properties
Article Number: 000054946
Article Type: Solution
Last Modified: 17 Oct 2025
Version: 3
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