NetWorker Module for Microsoft: Nsrpush cannot upgrade clients with NMM GLR installed

Summary: NetWorker NMC Push or Nsrpush is unable to upgrade NetWorker Module for Microsoft (NMM) clients with GLR installed.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker NMC Push or Nsrpush failed to upgrade the NetWorker clients when client machines have NetWorker Module for Microsoft (NMM) module installed.

From the log files, the following error is seen:     

nsrcpd NSR severe Error occurred in 'Upgrading' phase of client 'client_name': Feature 'NW_GLR_FEATURE' cannot be remotely upgraded.

Cause

This is expected behavior when NMM clients have the GLR feature installed. 

This does not happen if the NMM client has NMM installed without the GLR feature.

Resolution

When using NMC Software Upgrade (push) to upgrade a NetWorker Client that also has NetWorker Module for Microsoft installed, there are conditions to consider. These are the conditions for updating or upgrading NMM with NetWorker Software Upgrade feature (push).

Supported:     
NetWorker Module for Microsoft - Supports NMC push only

Not Supported:     
NetWorker Module for Microsoft - Does Not support CLI nsrpush

Restrictions:      

  • Select NetWorker and NetWorker Module for Microsoft (NMM) packages together for upgrades.  
  • Only NMM upgrade in a non-clustered environment is supported.  
  • Package Manager or Client Push does not support upgrade of NMM with GLR feature enabled


Resolution:     
If NMM is installed on the client Without GLR feature:    

  • Upgrade NetWorker Client and NMM - MUST select and upgrade both Client and NMM simultaneously.   
  • Use NMC Software Upgrade for this operation - Do Not use nsrpush CLI.


If NMM is installed on the client With GLR feature:     

  • Cannot upgrade NMM with NMC push because the GLR feature prevents the upgrade.   
  • Cannot upgrade NetWorker Client either with NMC push because upgrading the client alone without upgrading NMM is not supported. 

In the above case, the user must manually Remove NMM and NetWorker software and manually install the latest NetWorker Client and NMM software.    

Additional Information

This behavior was verified in NetWorker version 9.1, 9.0, and 8.2 and also verified in NetWorker 18.x and 19.x.

Affected Products

NetWorker, NetWorker Module for Microsoft
Article Properties
Article Number: 000061946
Article Type: Solution
Last Modified: 21 Jul 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.