Data Protection Advisor - Fatal LAX error when trying to install or upgrade DPA

Summary: Getting error: "Invocation of this Java Application has caused and InvocationTargetException. This application will now exit (LAX)" when trying to upgrade or install the DPA.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When attempting to install or upgrade the DPA datastore, the following error displays to the screen and the upgrade does not continue:

error screen

ERROR: "Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)"

Complete Error message: Invocation of this Java Application has caused and InvocationTargetException. This application will now exit (LAX)

The Details tab gives Java Lang error:
java.lang.NullPointerException
                at com.zerog.ia.installer.LifeCycleManager.getEnable8dot3(Unknown Source)
                at com.zerog.ia.installer.LifeCycleManager.a6(Unknown Source)
                at com.zerog.ia.installer.LifeCycleManager.executeApplication(Unknown Source)
                at com.zerog.ia.installer.Main.main(Unknown Source)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                at java.lang.reflect.Method.invoke(Method.java:498)
                at com.zerog.lax.LAX.launch(Unknown Source)
                at com.zerog.lax.LAX.main(Unknown Source)

Cause

Looking at the message in bold within the Error:

getEnable8dot3(Unknown Source)

This is not a DPA issue, but an issue on the Windows Registry that is missing a key.
On the server where you are attempting the install/upgrade, run the following command on a command prompt:
reg query HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem\ /v NtfsDisable8dot3NameCreation

It should return: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
    NtfsDisable8dot3NameCreation    REG_DWORD    0x2

However, if the following is returned, it confirms the problem:
This command resulted with the same message on both the application and datastore servers:
C:\Windows\system32>reg query HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem\ /v NtfsDisable8dot3NameCreation
 
ERROR: The system was unable to find the specified registry key or value

Resolution

The REG_DWORD    0x2 key can be added to the Windows registry.

Check with the customer OS/Windows security team as there can be a policy that is blocking the creation of this key.

Affected Products

Data Protection Advisor, Data Protection Suite Series
Article Properties
Article Number: 000261463
Article Type: Solution
Last Modified: 06 Feb 2025
Version:  1
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