PowerFlex UI unavailable/Cannot stop Presentation Server
Summary: PowerFlex UI unavailable/Cannot stop Presentation Server.
Symptoms
Symptoms
One or more of the following symptoms occurs:
- Cannot connect to PowerFlex UI
- PowerFlex UI unresponsive
- The Presentation Server (mgmt-server) process cannot be gracefully stopped
Impact
- The system cannot be administered using the PowerFlex user interface
- Presentation Server's host shutdown process may be delayed
Cause
Root Cause
A software issue may cause the Presentation Server process to become unresponsive after prolonged use.
Resolution
Workaround
Forcefully terminate the Presentation Server process.
Note down the process ID (PID) of the Presentation Server.
ps -ef |grep -v grep |grep com.emc.vxflexos.webui.backend.Server In the sample output below, the PID of the Presentation Server is 39449. mgmt-se+ 39449 1 9 Jun22 ? 1-09:40:08 /bin/java -Xmx4g -Djna.tmpdir=/opt/emc/scaleio/mgmt-server/tmp -Djava.io.tmpdir=/opt/emc/scaleio/mgmt-server/tmp -Dstorage.diskCache.bufferSize=2000 -Dlog4j2.configurationFile=/etc/mgmt-server/.config/log4j2.xml -cp /opt/emc/scaleio/mgmt-server/lib/* com.emc.vxflexos.webui.backend.Server -d metaData.dbType=Persistent
Terminate the Presentation Server process.
Replace with the PID noted down in the previous step.
Start with a normal kill:
kill <pid>
If this did not kill the process, (re-run the ps command above to verify) step up the kill command like this:
kill -HUP <pid>
If this did not kill the process, (re-run the ps command above to verify) step up the kill command again like this:
kill -9 <pid>
The reason User should not go to the last one first is that -9 does not give the process time to clean up after itself. Kill -9 should only be used as a last resort generally.