O Avamar Installer (AVI) para de responder ao tentar instalar um pacote AVP devido ao banco de dados bloqueado

Summary: O Avamar Installer (AVI) para de responder ao instalar um pacote AVP devido ao banco de dados bloqueado.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ambiente: O servidor Avamar versão v7.2.1-32, mas pode se aplicar a versões posteriores.

Ao instalar um pacote AVP, a interface do instalador do Avamar (AVI) para de responder.

progresso da instalação

Reiniciar o navegador mostra que o AVI está "instalando" o pacote no momento.
Selecionar Continuar não resulta em nenhum progresso.  
Página Sw Updates (Atualizações de software)
 
 
 

Cause

O registro do instalador do Avamar /usr/local/avamar/var/avi/server_log/avinstaller.log* mostra:
Jun 15, 2017 4:50:01 PM com.avamar.avinstaller.process.InstallManager install
INFO: Starting a new process instance.
Jun 15, 2017 4:50:01 PM com.avamar.avinstaller.process.UserInputManager getCurrentUserInput
INFO: Returned cached user input for checksum: bdc8a9876130f3199be845ca1d7866a5
Jun 15, 2017 4:50:01 PM com.avamar.avinstaller.process.PVM startProcessInstanceByKey
INFO: Starting processKey: upgrade-client-downloads20161009Oct101476054930 with userInputs: {}
Jun 15, 2017 4:50:01 PM org.hibernate.transaction.JDBCTransaction commit
SEVERE: JDBC commit failed
java.sql.SQLException: database is locked
at org.sqlite.DB.throwex(DB.java:855)
at org.sqlite.DB.exec(DB.java:138)
at org.sqlite.SQLiteConnection.commit(SQLiteConnection.java:512)
at org.hibernate.transaction.JDBCTransaction.commitAndResetAutoCommit(JDBCTransaction.java:170)
.
. -----------8<---------- SNIP!-----------8<---------- 
.
at com.avamar.avinstaller.process.InstallManager.install(InstallManager.java:125)
at com.avamar.avinstaller.monitor.Installer.run(Installer.java:46)
at java.lang.Thread.run(Unknown Source)
Caused by: java.sql.SQLException: database is locked

Conforme implícito pelas entradas de registro do avinstaller , o banco de dados avi PosgreSQL está bloqueado.
A causa raiz não é conhecida. O bug de 272057 documenta um cenário semelhante em que o AVinstaller falha ao gravar no banco de dados AVI.
Isso ocorria durante a operação de flush do MCS por hora.
Várias operações simultâneas que causamos ao banco de dados estão bloqueadas.

Resolution

Solução alternativa:
Reiniciar o AVI pode remover o bloqueio do banco de dados.
Os comandos abaixo mostram como interromper e, em seguida, iniciar AVIDB e tomcat.

Se o comportamento persistir, entre em contato com o Suporte Dell.
admin@avamar:~/>: sudo avinstaller.pl --help | grep "stop\|start"
--start                   starts avidb and tomcat if not up
--stop                    stops avidb and tomcat

Example:-
admin@avamar:~/>: sudo avinstaller.pl --stop
INFO: Waiting for Tomcat to shutdown
INFO: Shutting down avidb.
Stopping the database server.
Database server stopped.
INFO: Stopped the database.
 

admin@avamar:~/>: sudo avinstaller.pl --start
INFO: Starting avidb.
Starting the database server.
Waiting for postmaster to start .
Connected to DBI:Pg:dbname=postgres;port=5558.
INFO: Started the database.
/usr/local/avamar-tomcat/bin/startup.sh
Using CATALINA_BASE:   /usr/local/avamar-tomcat
Using CATALINA_HOME:   /usr/local/avamar-tomcat
Using CATALINA_TMPDIR: /usr/local/avamar-tomcat/temp
Using JRE_HOME:        /usr
Using CLASSPATH:       /usr/local/avamar-tomcat/bin/bootstrap.jar:/usr/local/avamar-tomcat/bin/tomcat-juli.jar
Tomcat started.

Affected Products

Avamar

Products

Avamar, Avamar Server
Article Properties
Article Number: 000046163
Article Type: Solution
Last Modified: 06 Feb 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.