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Article Number: 000052710


NDMP recovery fails with error "nsrndmp_recover: The NDMP connection is not successfully authorized on host ['ndmp_client_name']."

Summary: NDMP recovery fails with error "nsrndmp_recover: The NDMP connection is not successfully authorized on host ['ndmp_client_name']."

Article Content


Symptoms



NDMP recovery fails with error "nsrndmp_recover: The NDMP connection is not successfully authorized on host ['ndmp_client_name']."
Backups of the same client run successfully with no authentication error.

Sample error sequence in recovery output:
42880:nsrndmp_recover: Error during NDMP recover
42597:nsrndmp_recover: connect auth: permission problem
42610:nsrndmp_recover: The NDMP connection is not successfully authorized on host 'client_name'.
42847:nsrndmp_recover: Not able to connect or authorize the recover host 'client_name'
42840:nsrndmp_recover: NDMP recover failed.

Cause

The recovery is failing because the NDMP user authentication is failing on the NAS. This is almost always caused by incorrect NDMP account credentials specified in the NDMP client in NetWorker (wrong NDMP user or password).

NetWorker NDMP client backups reference the NDMP user and password specified in the particular client instance being backed up. However, NDMP recoveries may reference the NDMP user and password from any configured instance of the client, even client instances that are not actively backed up. Thus, if there are multiple NDMP client instances, a wrong NDMP user name or password in any one of those client instances may cause the recovery to fail with the above NDMP authentication error.

Resolution

To resolve the issue, first verify the correct NDMP user name and password for the client in question. To do that, from the NetWorker server, use the command 'ndmpsup -c [client_name]' to connect to the NAS and authenticate -- the command will prompt for the NDMP user and password to connect to the NAS and will output NAS details if successful or an authentication error if failed.

Once you have verified the NDMP account credentials edit every instance of the client in question and check the Remote User name and retype the password, then save the client. Since the password is a masked field, this must be done for every client instance to ensure the correct password is set.

Article Properties


Affected Product

NetWorker

Product

NetWorker

Last Published Date

20 Nov 2020

Version

2

Article Type

Solution