Unity/VNX/Celerra: Unable to Start CAVA Service on Window server (User Correctable)

Summary: When try to start CAVA service on window server, service cannot be started.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



On the Window server, the following messages are found:

Window could not start the EMC CAVA service on Local Computer
Error 1053: the service did not respond to the start or control request in a timely fashion.

From Window event log:
A timeout as reached 30000 millsec while waiting for the EMC CAVA service to connect.


On the data mover, the following general error messages are found:
[VNX/Celerra Examples]

[nasadmin@VNX01CS0 ~]$ server_viruschk server_2
server_2 :
10 threads started.
2 Checker IP Address(es):
10.xx.136.xxx OFFLINE at Fri Sep 15 02:01:41 2017 (GMT+10:00)
Unknown protocol, CAVA version:
AV Engine:
Server Name: 10.xx.136.xxx
No signature date

10.xx.136.xxx OFFLINE at Fri Sep 15 02:01:51 2017 (GMT+10:00)
Unknown protocol, CAVA version:
AV Engine:
Server Name: 10.xx.136.xxx
No signature date

2 File Mask(s):
*.* =.*
No file excluded.
Share \\nas01\CHECK$.
RPC request timeout=25000 milliseconds.
RPC retry timeout=5000 milliseconds.
High water mark=200.
Low water mark=50.
Scan all virus checkers every 10 seconds.
When all virus checkers are offline:
Continue to work with Virus Checking and CIFS.
Scan on read disable.
Panic handler registered for 65 chunks.
MS-RPC User: NAS01$
MS-RPC ClientName: nas01.xxx.xxx.xxx

[nasadmin@VNX01CS0 ~]$ nas_logviewer /nas/log/sys_log | grep -i VC
Sep 14 12:34:25 2017:DART:VC:NOTICE:17:Slot 2:::1505356456:The virus checker is started.
Sep 14 12:34:35 2017:DART:VC:ERROR:33:Slot 2:::1505356466:Error on CAVA server 10.xx.136.xxx: OFFLINE.
Sep 14 12:34:45 2017:DART:VC:ERROR:33:Slot 2:::1505356476:Error on CAVA server 10.xx.136.xxx: OFFLINE.
Sep 14 12:34:45 2017:DART:VC:ERROR:4:Slot 2:::1505356476:No virus checker server is available.
Sep 14 12:43:45 2017:DART:VC:NOTICE:16:Slot 2:::1505357023:The virus checker is stopped.
~~
Sep 14 12:46:35 2017:DART:VC:NOTICE:16:Slot 2:::1505357191:The virus checker is stopped.
Sep 14 14:13:35 2017:DART:VC:NOTICE:17:Slot 2:::1505362408:The virus checker is started.
Sep 14 14:13:45 2017:DART:VC:ERROR:33:Slot 2:::1505362418:Error on CAVA server 10.xx.136.xxx: OFFLINE.
Sep 14 14:13:55 2017:DART:VC:ERROR:33:Slot 2:::1505362428:Error on CAVA server 10.xx.136.xxx: OFFLINE.
Sep 14 14:13:55 2017:DART:VC:ERROR:4:Slot 2:::1505362428:No virus checker server is available.

[Unity Examples]

14:26:30 service@VIRT1615YRRR08-spa spa:~> svc_cava cava-smb
cava-smb : commands processed: 1
command(s) succeeded
output is complete

1507818392: VC: 5: VDM cava-smb: Enabled and Started.
1507818392: VC: 5: 1 Checker IP Address(es):
1507818392: VC: 5: 5.6.7.246                                      OFFLINE at Thu Oct 12 14:26:29 2017 (GMT-00:00)
1507818392: VC: 5:                                                HTTP, CAVA version: , httpStatus: 1006 Connection Disconnected
1507818392: VC: 5:                                                AV Engine:
1507818392: VC: 5:                                                Server Name: 5.6.7.246
1507818392: VC: 5:                                                No signature date
1507818392: VC: 5:
1507818392: VC: 5: 1 File Mask(s):
1507818392: VC: 5: *.*
1507818392: VC: 5: No file excluded.
1507818392: VC: 5: Share \\5.6.7.56\CHECK$.
1507818392: VC: 5: RPC request timeout=25000 milliseconds.
1507818392: VC: 5: RPC retry timeout=5000 milliseconds.
1507818392: VC: 5: High water mark=200.
1507818392: VC: 5: Low water mark=50.
1507818392: VC: 5: Scan all virus checkers every 10 seconds.
1507818392: VC: 5: When all virus checkers are offline:
1507818392: VC: 5: Continue to work with Virus Checking and CIFS.
1507818392: VC: 5: Scan on read disable.
1507818392: VC: 5: MS-RPC User: CAVA-SMB$
1507818392: VC: 5: MS-RPC ClientName: cava-smb.PEEPS.LAB
1507818392: ADMIN: 6: Command succeeded:  viruschk
14:26:32 service@VIRT1615YRRR08-spa spa:~>

[/EMC/C4Core/log/c4_safe_ktrace.log]

2017/10/12-14:31:55.028840  582     7FC1F33C9701     sade:VC: 5:[cava-smb]  Enable file system 536870934 for virus checking.
2017/10/12-14:31:55.028879   36     7FC1F33C9701     sade:VC: 5:[cava-smb]  Enable file system 536870933 for virus checking.
2017/10/12-14:31:55.028947   66     7FC1F33C9701     sade:VC: 5:17:[cava-smb]  The virus checker is started.
2017/10/12-14:31:55.053859  24K     7FC1F33C9701     sade:VC: 3:34:[cava-smb]  The virus checker server 5.6.7.246 has encountered an error and is no longer operational.(Error: OFFLINE,
2017/10/12-14:31:55.053864    4     7FC1F33C9701     sade:VC: 3:34:[cava-smb]  httpStatus: 1006 Connection Disconnected)
2017/10/12-14:31:55.053879   13     7FC1F33C9701     sade:VC: 3: 4:[cava-smb]  No virus checker server is available.
2017/10/12-14:31:55.053888    7     7FC1F33C9701     sade:VC: 5:[cava-smb]  Total Requests: 0.
2017/10/12-14:31:55.053893    3     7FC1F33C9701     sade:VC: 5:[cava-smb]
2017/10/12-14:31:55.053899    4     7FC1F33C9701     sade:VC: 5:[cava-smb]  NO ANSWER from the Virus Checker Servers: 0.
2017/10/12-14:31:55.053932   31     7FC1F33C9701     sade:VC: 5:[cava-smb]  ERROR_SETUP: 0.
2017/10/12-14:31:55.053938    5     7FC1F33C9701     sade:VC: 5:[cava-smb]  FAIL: 0.
2017/10/12-14:31:55.053945    4     7FC1F33C9701     sade:VC: 5:[cava-smb]  TIMEOUT: 0.
2017/10/12-14:31:55.053949    2     7FC1F33C9701     sade:VC: 5:[cava-smb]
2017/10/12-14:31:55.053956    4     7FC1F33C9701     sade:VC: 5:[cava-smb]  0 files in the collector queue.
2017/10/12-14:31:55.053961    3     7FC1F33C9701     sade:VC: 5:[cava-smb]  0 files processed by the AV threads.

Cause

When a service starts, the service communicates to the Service Control Manager how long the service must have to start (the timeout period for the service). If the Service Control Manager does not receive a "service started" notice from the service within this timeout period, the Service Control Manager terminates the process that hosts the service. This timeout period is typically less than 30 seconds.

.NET Framework system requirements for Windows 8 and Windows Server 2012 Windows 8 and Windows Server 2012 install and enable by default the .NET Framework 4.5. However, the CEE Framework, "cava.exe", is a .NET Framework 3.5 service. You must enable .NET Framework 3.5. The Microsoft website contains instructions on enabling the .NET Framework 3.5 on Windows 8 and Windows 2012 at: http://msdn.microsoft.com/ens/library/hh506443.aspx

Resolution

Install or enable the .NET Framework 3.5 on Windows 10, Windows 8.1, and Windows 8
https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10

Once .NET Framework 3.5 is running and CAVA service started properly.
Data mover can detect CAVA server ok.

Affected Products

VNX/VNXe

Products

Celerra, Dell EMC Unity Family, VNX/VNXe
Article Properties
Article Number: 000065188
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.