PowerProtect – Mehrere VM-Backups schlagen mit dem Fehler "Cannot connect to backup server" fehl.

Summary: PowerProtect Data Manager-Appliance DM5500: In diesem Artikel wird ein seltenes Szenario mit einem stark belasteten System beschrieben. Ein VMware VADP-Workload mit bestimmten Einstellungen, die in der Policy aktiviert sind, wirkt sich auf interne Verbindungen zum Speichersystem aus. ...

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Symptoms

Betroffene Versionen: Die DM5500 5.13, 5.14 sind betroffen.

Dm5500 und vCenter werden mit laufenden stündlich ausgeführten VADP-Backups geladen, wobei Swap File exclusion und metadata Indexing konfiguriert sind.

Nach einiger Zeit schlägt ein System mit der obigen Konfiguration VM-Backups mit dem Fehler fehl:
"Cannot connect to backup server:  [5040]". 

In den Protokollen gefundene Symptome: 

2023-07-03T05:03:00.219Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Concurrent open DD Boost connections = 31.
2023-07-03T05:03:00.219Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Access to DD Boost connection delayed by 8.756µs.
2023-07-03T05:03:00.219Z DEBUG:  [a7355c162f90883e] Sending state of 'Running' (last: state=Queued, progress=0).
2023-07-03T05:03:08.224Z ERROR:  [a7355c162f90883e] TaskEngine-0: Cannot connect to backup server :  [5040] calling system(), returns nonzero
2023-07-03T05:03:08.225Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Task[1].Undo
2023-07-03T05:03:08.225Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Task[0].Undo
2023-07-03T05:03:08.225Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Releasing ProxyReservationSessions:53e5a903-afa9-467a-98ab-xxxxxxxxx
2023-07-03T05:03:08.225Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Sending release reservation to VISD: release/vm/0


 


Cause

Das System ist aus einer VMware VADP-Workload-Perspektive mit der Option "swapfile exclusion" stark geladen.

Die "Metadatenindizierung" kann für Policies aktiviert sein oder nicht. 

Im Laufe der Zeit verbraucht das System alle internen Verbindungen zum Speichersystem.

Wenn die Ressourcen für die VM-Schutz-Engines oder vCenter knapp werden, werden verbindungen, die mit den Speichersystemen erstellt werden, nicht bereinigt.

Im Laufe der Zeit tritt ein Verbindungsleck auf und dies führt dazu, dass Backups angehalten werden.


Resolution

Lösung:
Wenden Sie sich an den Dell Support, um die neuesten Informationen zu erhalten.

Problemumgehung:
    1. Identifizieren Sie die VM Protection Engine, in der der Fehler auftritt. Starten Sie die VM-Schutz-Engines in der Benutzeroberfläche von PowerProtect Data Manager neu: 

PPDM-Benutzeroberfläche

    2. Fügen Sie zusätzliche VM-Schutz-Engines über die -Benutzeroberfläche hinzu. Dies reduziert die Last auf die vorhandenen VM-Schutz-Engines.
    3. Deaktivieren Sie die Option Swap File exclusion (Dateiausschluss tauschen) aus den Schutz-Policies. Dadurch wird die Last auf den VM-Schutz-Engines weiter reduziert.

Affected Products

PowerProtect DM5500
Article Properties
Article Number: 000216108
Article Type: Solution
Last Modified: 21 Sep 2023
Version:  2
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