PowerProtect: i backup multipli di più VM hanno esito negativo con errore "Cannot connect to backup server"

Summary: PowerProtect Data Manager Appliance DM5500: Questo articolo descrive uno scenario raro con un sistema sovraccarico. Un carico di lavoro VMware VADP con impostazioni specifiche abilitate nella policy influisce sulle connessioni interne al sistema di storage. ...

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Symptoms

Versioni interessate: Sono interessati DM5500 5.13 e 5.14.

DM5500 e vCenter vengono caricati con backup VADP orari con esclusione di file di swap e indicizzazione dei metadati configurati.

Dopo un certo periodo di tempo, in un sistema con la configurazione di cui sopra i backup delle VM hanno esito negativo con l'errore:
"Cannot connect to backup server:  [5040]". 

Sintomi riscontrati nei log: 

2023-07-03T05:03:00.219Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Concurrent open DD Boost connections = 31.
2023-07-03T05:03:00.219Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Access to DD Boost connection delayed by 8.756µs.
2023-07-03T05:03:00.219Z DEBUG:  [a7355c162f90883e] Sending state of 'Running' (last: state=Queued, progress=0).
2023-07-03T05:03:08.224Z ERROR:  [a7355c162f90883e] TaskEngine-0: Cannot connect to backup server :  [5040] calling system(), returns nonzero
2023-07-03T05:03:08.225Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Task[1].Undo
2023-07-03T05:03:08.225Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Task[0].Undo
2023-07-03T05:03:08.225Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Releasing ProxyReservationSessions:53e5a903-afa9-467a-98ab-xxxxxxxxx
2023-07-03T05:03:08.225Z DEBUG:  [a7355c162f90883e] TaskEngine-0: Sending release reservation to VISD: release/vm/0


 


Cause

Il sistema è pesantemente caricato dal punto di vista del carico di lavoro VMware VADP con l'opzione "esclusione di swapfile".

L'"indicizzazione dei metadati" può essere abilitata o meno nelle policy. 

Nel corso del tempo, il sistema esaurisce tutte le connessioni interne al sistema di storage.

Quando gli engine di protezione delle VM o vCenter esauriscono le risorse, le connessioni create con i sistemi di storage non vengono pulite.

Nel corso del tempo, si verifica una perdita di connessione e ciò causa lo stallo dei backup.


Resolution

Correzione:
Contattare il supporto Dell per le informazioni più recenti.

Soluzione:
    1. Identificare l'engine di protezione delle VM in cui si verifica l'errore. Riavviare gli engine di protezione delle VM nell'interfaccia utente di PowerProtect Data Manager: 

PPDM UI

    2. Aggiungere altri engine di protezione delle VM dall'interfaccia utente. In questo modo si riduce il carico sugli engine di protezione delle VM esistenti.
    3. Disabilitare l'opzione di esclusione Swap File dai criteri di protezione. In questo modo si riduce ulteriormente il carico sugli engine di protezione delle VM.

Affected Products

PowerProtect DM5500
Article Properties
Article Number: 000216108
Article Type: Solution
Last Modified: 21 Sep 2023
Version:  2
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