Latitude 5330 Does Not Turn On or Shuts Down with Powered USB Type-C Third-Party Device Connected

Summary: The following article provides information about resolving a laptop No Power, or Shut Down problem on the Latitude 5330 laptop. The laptops either does not turn on or shuts down to off with a third-party device using a powered USB Type-C cable connected. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The laptop does not turn on or shuts down after plugging a third-party powered USB type-C cable to the Latitude 5330

 

Dell Latitude 5330 laptop owners may experience a No Power issue where the laptop either does not turn on or it shuts down to off.

The power problem happens under the following circumstances:

  • An external third-party monitor that connects to the laptop using a USB Type-C cable that is supplying power from the monitor to the laptop:
    • The laptop may not turn on if the cable is already plugged in when you press the power button.
    • Where the laptop is powered on and you plug in the cable the laptop shuts down and turns off.
    • This may happen on the first time the cable is plugged in, or after several successful connections.
  • An external third-party AC adapter that connects to the laptop using a USB Type-C cable that is supplying power from the adapter to the laptop:
    • The laptop may not turn on if the cable is already plugged in when you press the power button.
    • Where the laptop is powered on and you plug in the cable the laptop shuts down and turns off.
    • This may happen on the first time the cable is plugged in, or after several successful connections.
  • The Latitude 5330 laptops BIOS is within the following range:
    • 1.5.0 to 1.15.0
Note: Dell does not support or advise that you connect third-party AC adapters and third-party devices that supply power to Dell products. Dell Technologies recommends purchasing Dell external devices that have been tested as working with the product.

Cause

This section is not applicable to this article.

Resolution

Updating the laptop to version 1.16.1 of the BIOS or newer prevents this issue from occurring. Download and install the latest BIOS:

Warning: Dell Technologies recommends disconnecting devices before updating the BIOS. (For example: External hard drives, printers, scanners, and so on.)

 

Warning: Dell laptops must have the battery installed and charged to at least 10% before you begin the BIOS update. Dell Technologies recommends connecting the laptop to Dell AC power before proceeding with the update process.

 

Note: To learn more about updating the BIOS on a Dell laptop, see the Dell Technologies knowledge base article: BIOS Update Guide

 

Note: To install or update the BIOS, your user account must have administrator privileges.

 

  1. Browse to: Latitude 5330 Laptop Drivers & Downloads page

  2. Select the Operating System that is running on the laptop.

  3. Under Category, select BIOS.

  4. Locate the latest Dell Latitude 5330 System BIOS update. (Version 1.16.1 or newer.)

  5. Click Download and save the file to your laptop.

  6. Open File Explorer and browse to the download folder where it saves the download file.

  7. Double-click the download BIOS update file and follow the on-screen instructions to complete the installation process.

  8. The laptop restarts as part of the installation process and boots back into the operating system.

Affected Products

Latitude 5530
Article Properties
Article Number: 000223279
Article Type: Solution
Last Modified: 13 Nov 2025
Version:  5
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