Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell Unity: Pre-Upgrade Health Check failed with error check_connectemc_sender_1 (Dell Correctable)

Summary: Pre-Upgrade Health Check (PUHC) fails with error: ERROR_CODE=platform::check_connectemc_sender_1|Error|UPGRADE CANNOT PROCEED.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Pre-Upgrade Health Check (PUHC) fails with error: 
ERROR_CODE=platform::check_connectemc_sender_1|Error|
UPGRADE CANNOT PROCEED.
check_connectemc_sender_1
errors :0x1000300- Operation failed. Error code: 0x1000300 The requested object could not be found on the system. Recheck the command name. 0x6400bee - Failed to perform the operation because connect home has not been configured

Cause

Starting with Unity OE 5.3, ConnectHome connectivity notifications using <serialNumber>@dell.com are no longer the default.
When configuring ConnectHome connectivity, include an email address from the system's domain name or an applicable email address that passes authentication from your SMTP server. 

In order to enable SupportAssist in 5.3 and later, ConnectEMC must have a "from" email address.

Resolution

There are two options to resolve this issue.

1. Skip the PUHC and perform the upgrade. Add the from email address later.
2. Add the from email address now and then perform the upgrade.

Option 1: Skip the PUHC and perform the upgrade
  1. Run the below command:
svc_skip_puhc
  1. Run the below command to skip the error:
+58

50: flr::check_for_disk_transitions
51: flr::check_for_faulted_disks
52: flr::check_for_no_pulled_disks
53: flr::check_for_snaps_in_an_active_state
54: flr::check_movesession_exists
55: slic::check_for_slic_committed
56: platform::check_centralized_esrs_version
57: platform::check_unsupported_proxy
58: platform::check_connectemc_sender
  1. Once the check_connectemc_sender is skipped, start the upgrade from Unisphere.
  2. Add the from email address for ConnectEMC.  (See below)
Option 2: Add the from email address and then upgrade

There are three options to add the from email address:
  1. Unisphere
  2. svc_connectemc commands
  3. uemcli commands
Unisphere:

SMTP

svc_connectemc:
  1. Run the below command to display ConnectEMC status:
svc_connectemc -s

ConnectEMC: NOTRUNNING DISABLE
      2.Test the capability of ConnectEMC to send a message to support with the below command:
spa:/cores/service/user# svc_connectemc -t

ERROR [spa]: Email (ConnectEMC) not configured
    3.  Run the below command to display ConnectEMC configuration details:
svc_connectemc -g

INFO [spa]: SMTP Host: smtp.server.com
INFO [spa]: SENDER EMAIL: DP-Unity01@dell.com
INFO [spa]: EMC Destination Email: emailalert@emc.com
   4. Run the below command to set the email address ConnectEMC uses to send alerts:
05:57:12 root@CKM002XXXXX929 spa:/cores/service/user# svc_connectemc -m DP-Unity01@dell.com

INFO [spa]: Verifying peer connectivity ...
ERROR [spa]: Email (ConnectEMC) not configured. Please enable connetEMC first.
   5. Run the below command to enable ConnectEMC:
05:58:30 root@CKM002XXXXX929 spa:/cores/service/user# svc_connectemc --enable 10.1XX.1XX.1X1 --sendermail DP-Unity01@dell.com

INFO [spa]: Verifying peer connectivity ...
INFO [spa]: Enabling ConnectEMC
INFO [spa]: Verifying peer connectivity ...
INFO [spa]: copying connectEMC config to peer
INFO [spa]: Persisting SMTP server configuration
INFO [spa]: Persisting sender email address configuration
INFO [spa]: ConnectEMC has been enabled successfully.
  1. After enabling ConnectEMC, test the connection: 
    svc_connectemc -t
    INFO [spa]: Test Dialhome request 

uemcli:

  1. Run the below command to list the current configuration:
    uemcli /sys/support/connecthome show -detail
    
    1:  Enabled       = yes
       SMTP server     = 10.1XX.1XX.1X1
       E-mail from address = (none)@emc.com 
       E-mail to address  = emailalert@emc.com
Before enabling ConnectEMC, if you verify the test command it fails with an error: 
Operation failed. Error code: 0x1000300
The requested object could not be found on the system. Recheck the command name. (Error Code:0x1000300)
      2.  Run the below command to enable the ConnectEMC: 
uemcli -d 10.0.0.1 -u local/joe -p Password /sys/support/connecthome set –enable yes –smtpServer 10.10.22.22 -emailFromAddr DP-Unity01@dell.com
  1. After enabling ConnectEMC, if you test it, it passes successfully:
    09:05:02 root@CKM002XXXXX929 spb:/cores/service/user# uemcli -u admin -securepassword /sys/support/connecthome test
    Password:
    Storage system address: 127.0.0.1
    Storage system port: 443
    HTTPS connection
    
    Remote certificate:
    Issuer:   CN=DP-UNITY01
    Subject:  CN=DP-UNITY01
    Valid from: 2020:06:14:07:13:27
    Valid to:  2023:06:14:07:13:27
    Serial:   00a382cb17422be9fd
    Id:     2957123456
    Would you like to:
     [1] Accept the certificate for this session
     [2] Reject the certificate
    Please input your selection (The default selection is [1]):
    Operation completed successfully.
4. List the current details after the configuration change:
uemcli /sys/support/connecthome show -detail

Please input your selection (The default selection is [1]):
1:  Enabled       = yes
   SMTP server     = 10.1XX.1XX.1X1
   E-mail from address = DP-Unity01@dell.com
   E-mail to address  = emailalert@emc.com

Additional Information

Article Properties


Affected Product

Dell EMC Unity Family

Last Published Date

29 Apr 2024

Version

1

Article Type

Solution